?>
Дан массив a, состоящий из n целых неотрицательных чисел. Ваша задача — построить по нему массив b, задающийся следующей формулой: bi=(ai, 2⋅ai, если ai — нечетное число;если ai — четное число.) Оба массива нумеруются, начиная с 0 (например, массив a имеет вид a0, a1, a2, ..., an−1 Формат входных данных В первой строке входных данных находится натуральное число n — количество элементов массива (n≤500). Во второй строке вводятся n целых неотрицательных чисел, разделённых пробелами — элементы этого массива. Элементы массива не превосходят 1000. Формат выходных данных Выведите на экран n целых неотрицательных чисел, разделённых пробелами — элементы массива b. входные данные 4 1 3 3 7 5 4 20 412 3 2 выходные данные 1 3 3 7 8 40 824 3 4
Ответы
int n = Convert.ToInt32(Console.ReadLine())
Объяснение:
Это Ввод данных. Первые две задачи выполнены хорошо. Если хочешь вводить число n , то в вызове метода убери параметры и оставь свободным.
static void Main()
{
(10,45);
ShowSequenceOfOddNumbers(5);
CreateAndShowArray(); // Вот так
}
А чтоб вводить число добавь строку "Ввода данных"
int n = Convert.ToInt32(Console.ReadLine())
Например:
tatic void CreateAndShowArray() // Пустой параметр
{
int n = Convert.ToInt32(Console.ReadLine())
long p = 1;
for (int i = 0; i < n; i++)
{
a[i] = new Random().Next(0, 100);
Console.Write(a[i] + " ");
p *= a[i];
}