myudanova631
?>

Паскаль. Составить программу вычисления следующего выражения: 3x²+2x ÷ ( x-1 )( x-2 ) + 3√x+1 ÷ x² ( чтобы вводилось значение X Заранее .

Информатика

Ответы

КутузоваМартенюк

#include <iostream>

#include <math.h>

#include <conio.h>

#include <locale.h>

using namespace std;

int main()

{

   setlocale(LC_CTYPE, "");

   double  a, b, c;

   cout << "a = "; cin >> a; cout << endl;

   cout << "b = "; cin >> b; cout << endl;

   cout << "c = "; cin >> c; cout << endl;

   if ((a >= b + c) || (b >= a + c) || (c >= a + b))

   {

       cout << "Это не треугольник" << endl;

   }

   else if (a*a + b*b == c*c)

   {

       cout << "Это прямоугольный треугольник" << endl;

   }

   else if ((a*a + b*b > c*c) && (a*a + c*c > b*b) && (c*c + b*b > a*a))

   {

       cout << "Это остроугольный треугольник" << endl;

   }

   else

   {

       cout << "Это тупоугольный треугольник";

   }

       system("pause");

   return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. Составить программу вычисления следующего выражения: 3x²+2x ÷ ( x-1 )( x-2 ) + 3√x+1 ÷ x² ( чтобы вводилось значение X Заранее .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kolesnikovaen
mlubov1
cernovarmechta
arch5050
Gulyaev_Egorkina
lanabogd
juli19657
info46
marat7
Svetlana1287
Pirogovskii695
ALLA1868
prostopo4ta29
Vladimirovna Yevtodeva
Yevgenevna