Panei
?>

Напишите программу на Python для следующей задачи: "Среди четырехзначных чисел выбрать те, у которых все четыре цифры различны. "

Информатика

Ответы

Aleksei1968

Объяснение:

n = int(input()) - #сколько чисел

for i in range(n):

   a = int(input()) #вводим числа

   if a %10 != a//10%10 and a %10 != a//100 and a //10 %10 != a//100:  #проверяем чила

       print('Yes')

   else:

       print('No')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на Python для следующей задачи: "Среди четырехзначных чисел выбрать те, у которых все четыре цифры различны. "
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

emilbadalov
Агибалов428
Galinova2911
Nekrasova
osnovnoisklad3551
Sergeevich-Novikov
Lyalikova
elbabitch2014
format-l3364
BelyaevNadezhda223
serkinn69
Voronin-Albertovich
YaroslavSerganYS5
nestruev
Некрасов Валентина1097