alexeytikhonov
?>

Цикл While, Паскаль, Найти сумму четных цифр числаСоставить таблицу значений функции y = 5 - x2/2 на отрезке [-5; 5] с шагом 0, 5.Написать программу, подсчитывающую количество четных и нечетных цифр в числе.Сумма и произведение цифр числа

Информатика

Ответы

qadjiyevaaynura

import random

def GenEx(count):

   signs = ['+', '-', '*', '/']

   for _ in range(count):

       fn = random.randint(-20, 20)

       sn = random.randint(-20, 20)

       ex = '{0} {1} {2}'.format(fn, random.choice(signs), sn)

       yield (ex + ' = ?', eval(ex))

IsGameRun = True

while IsGameRun:

   TrueAnsws = 0

   for ex, check in GenEx(2):

       print(ex)

       resvAnsw = float(input())

       if resvAnsw == check: TrueAnsws += 1;

   

   IsRetry = input('You correctly solved '+str(TrueAnsws)+' examples. Do you want to try again? Y/N \n')

   if IsRetry == 'Y': IsGameRun = True

   else: IsGameRun = False

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Цикл While, Паскаль, Найти сумму четных цифр числаСоставить таблицу значений функции y = 5 - x2/2 на отрезке [-5; 5] с шагом 0, 5.Написать программу, подсчитывающую количество четных и нечетных цифр в числе.Сумма и произведение цифр числа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annasolod
infocenterbla
Исаченко Тераски1181
ams-sim
vikashop269
whiskyandcola
Yurevich-Vladimirovich
andy74rus36
avdeevo
luza5
Malenyuk
alfaantonk
emik071089
anton
Borisovich-Volobueva1803