Norov
?>

Составьте программу и начертите блок-схему (используя цикл с предусловием) для вычисления функции у=3√х²+1, если х=4, 7, 10, 13, 16, 19, 21.

Информатика

Ответы

teta63
Если это паскаль, то вот.
var x,y:integer;
begin
y:=1;
x:=4;
while not (x=24) do
 begin
 y:=3*(sqrt(x*x + 1));
writeln("для х= ", x, "y= ", y);
x:=x+3;
end;
end.
pokrov777krest
1. Разностная машина Беббиджа должна была заменить группу вычислителей, которые аккуратно склвдывали и вычитали числа. Поэтому утверждение "Б" - справедливо
2. Подготовка данных с перфокарт, утверждение "А" - справедливо.
3. Утверждение "Г" - спорно, хотя в 2000 году в лондонском Музее науки заработал принтер, придуманный Бэббиджем для своей машины.

Вообще машина проектировалась как механический аппарат предназначенный для автоматизации вычислений путем аппроксимации функций многочленами и вычисления конечных разностей.
Sergei
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=5;

Var
 ma:array[1..n,1..n] of integer;
 i,j,max,maxj,a:integer;
begin
max:=-1;
randomize;
 writeln('Matrix:');
  for i:=1 to n do
   begin;
   for j:=1 to n do
    begin;
     ma[i,j]:=random(10);
     write(ma[i,j]:4);
    end;
   writeln;
   end;
  for j:=1 to n do
  begin
   for i:=1 to n do
     a:=a+ma[i,j];
   if a>max then
    begin
     max:=a;
     maxj:=j;
    end;
    a:=0;
  end;
write('Максимальный по сумме столбец:',maxj);
end.

Пример работы кода:
Matrix:
   8   6   8   0   2
   6   1   2   9   8
   8   1   8   0   1
   4   5   1   5   2
   3   0   9   9   5
Максимальный по сумме столбец:1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу и начертите блок-схему (используя цикл с предусловием) для вычисления функции у=3√х²+1, если х=4, 7, 10, 13, 16, 19, 21.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Belov
Nikolaevich824
Алена
tatyanakras911248
martinzdraste
АлександровнаВладимирович1424
satinvova
AlekseiMardanova
АлександровнаАслан1571
danaya3005
books
Irina_Nikolai
Bmashutav16
Оксана
myxa120283