igor51766771
?>

Напишите рекурсивную функцию перевода целого неотрицательного числа из десятичной системы счисления в двоичную. Формат входных данных На вход ваша программа получает одно число — N (0≤N≤500000 Формат выходных данных Выведите число N в двоичной системе счисления. входные данные 42 9 выходные данные 101010 1001

Информатика

Ответы

stsnab

Объяснение:

#include <iostream>

#include <vector>

#include <string>

int main()

{

int n;

std::cin >> n;

std::vector<int> bin;

for (;;) {

 if (n <= 0) {

  break;

 }

 bin.push_back(n % 2);

 n /= 2;

 

}

int bin_size = bin.size();

for (int i = 0; i < ( bin_size) ;i++) {

  std::cout << bin.back();

  bin.pop_back();

 

}

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите рекурсивную функцию перевода целого неотрицательного числа из десятичной системы счисления в двоичную. Формат входных данных На вход ваша программа получает одно число — N (0≤N≤500000 Формат выходных данных Выведите число N в двоичной системе счисления. входные данные 42 9 выходные данные 101010 1001
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maria
Bondarev_Ayupova795
Zashchitin Denis
bolosolo77
baton197310
Матвеев
Posadskii-Sergeevna
Анатольевич-Лариса
stanefimov
mnogomams47
predatorfishing608
Anatolii
kozhevniks
Tarapovskaya
Zakharov Lilit