?>
Напишите программу, которая переводит число (возможно, отрицательное), записанное в шестнадцатеричной системе, в десятичную систему. Входные данные Входная строка содержит шестнадцатеричную запись числа N ( 1 ≤ | N | < 10 9 Выходные данные Программа должна вывести десятичную запись этого числа
Ответы
Числа можно вводить
int k,l; cout<<"->"; cin>>k>>l; if (k==l) { k=0; l=0; cout<<k<<" "<<l<<endl; } else { l=k; cout<<k<<" "<<l<<endl; }
если хочешь без ввода удали cin и присвой значения
2.
int k,l,z; cout<<"->"; cin>>k>>l>>z; if (k>0) { k*=k; cout<<k<<endl; } if (l>0) { l*=l; cout<<l<<endl; } if (z>0) { z*=z; cout<<z<<endl; } if (k<0) { cout<<k<<endl; } if (l<0) { cout<<l<<endl; } if (z<0) { cout<<z<<endl; }