?>
1. Вычислите результат целочисленного деления и остаток от деления a) 217/6 = ...b) 190%9 = ...2. Напишите программу для округления числа до ближайшего большего ( 31, 04; 21, 015;)3. Напишите программу для вычисления значения выражения : 4. Даны два числа . Вывести меньшее из них ( написать программы )
Ответы
//Pascal ABC.NET v3.1 сборка 1172
Const
n=20;
Var
ar:array[1..n] of integer;
i:integer;
begin
randomize;
writeln('First array:');
for i:=1 to n do
begin
ar[i]:=random(10)-3;
write(ar[i]:4);
if ar[i]>0 then ar[i]:=ar[i]*2 else ar[i]:=0;
end;
writeln;
writeln('Final array:');
for i:=1 to n do
write(ar[i]:4);
end.
Пример работы программы:
First array: 2 -3 5 6 -3 -3 1 -2 -3 1 3 -3 4 -3 1 -1 6 6 2 3
Final array: 4 0 10 12 0 0 2 0 0 2 6 0 8 0 2 0 12 12 4 6