Stefanidi_Semeikina1896
?>

написать программу на питоне. На доске стоит белая шашка. Требуется определить, может ли она попасть в заданную клетку, делая ходы по правилам (не превращаясь в дамку Назад шашка ходить не может. Ввод - две клетки вида а1 c2 ( 4 цифры, как координаты), они гарантированно не совпадают

Информатика

Ответы

Daletskaya Sergei1121
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var k:=0;
  var n:=ReadInteger();
  var nmax:=0;
  while n<>0 do begin
    Inc(k);
    if n mod 10 = 0 then
      if n>nmax then nmax:=n;
    n:=ReadInteger()  
    end;
  var cntrl:=ReadInteger();
  Writeln('Получено ',k,' чисел');
  Writeln('Полученное контрольное значение: ',cntrl);
  Writeln('Вычисленное контрольное значение: ',nmax);
  if cntrl=nmax then Writeln('Контроль пройден')
  else Writeln('Контроль не пройден')
end.

Тестовое решение:
53
16
40
9
10
32
74
0
40
Получено 7 чисел
Полученное контрольное значение: 40
Вычисленное контрольное значение: 40
Контроль пройден

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу на питоне. На доске стоит белая шашка. Требуется определить, может ли она попасть в заданную клетку, делая ходы по правилам (не превращаясь в дамку Назад шашка ходить не может. Ввод - две клетки вида а1 c2 ( 4 цифры, как координаты), они гарантированно не совпадают
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bksenia9775
shakmeev
kashxb2056
aksmobile
irohmichaelchikaodiri
thedoomsdatdcs36
infosmolenskay
petrova-kate3
ams-sim
ortopediya
bellaalya13862
baranovaas
nsn-2012
marinakmaa86
shumeikoElena362
▲