tyrnaus
?>

Составьте программу, которая будет будет просить человека ввести имеющуюся у него сумму денег? присваивать введенные данные переменной sum, а потом выводить три варианта ответа в зависимости отимеющейся у посетителя суммы. При этом система выводит следующие варианты ответов в зависимости отвведенной суммы:1. если сумма составляет менее 500 тенге - "У Вас недостаточно денег на билет."2. от 500 до 5000 - "У Вас хватает денег на просмотр фильма в нашем кинотеатре." З. свыше 5000 - "Вы можетеСмотреть кино весь день."Прикрепите написанную программу в виде файла в одном из следующих форматов: doc, jpeg, bmp, jpg.​

Информатика

Ответы

artemka56rus
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var n:=ReadInteger('Число строк (столбцов) матрицы:');
  Writeln('Введите элементы матрицы построчно');
  var a:array[,] of integer;
  SetLength(a,n,n);
  for var i:=0 to n-1 do
    for var j:=0 to n-1 do Read(a[i,j]);
  var s:=0;
  for var i:=0 to n-1 do s+=a[i,i];
  Writeln('Сумма элементов главной диагонали равна ',s)
end.

Тестовое решение
Число строк (столбцов) матрицы: 3
Введите элементы матрицы построчно
1 6 3
8 4 9
0 1 7
Сумма элементов главной диагонали равна 12

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая будет будет просить человека ввести имеющуюся у него сумму денег? присваивать введенные данные переменной sum, а потом выводить три варианта ответа в зависимости отимеющейся у посетителя суммы. При этом система выводит следующие варианты ответов в зависимости отвведенной суммы:1. если сумма составляет менее 500 тенге - "У Вас недостаточно денег на билет."2. от 500 до 5000 - "У Вас хватает денег на просмотр фильма в нашем кинотеатре." З. свыше 5000 - "Вы можетеСмотреть кино весь день."Прикрепите написанную программу в виде файла в одном из следующих форматов: doc, jpeg, bmp, jpg.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

julianikaleksandrova
tenvalerij
Рамиль211
info126
itartdesignprof
Демидова Красноцветов
aromastil88
Olga-Lev1160
Станиславович ыфвыв
oslopovavera
Николаев
lukur2005
Ka2ffka141
Obukhov-Buriko
Andreeva