Максим
?>

Решите сегодня на языке python Совпадающие начало и конец Дана строка. Требуется найти самую длинную её подстроку, у которой совпадает первый и последний символы. Если подходит несколько подстрок, то выведите любую из них. Входные данные На вход подаётся одна строка из строчных латинских букв длиной не более 100 символов. Выходные данные Выведите ответ на задачу.

Информатика

Ответы

Владимирович_Роман

s = input()

ans = ''

for i in range(len(s)):

   j = s.rfind(s[i]) + 1

   if j - i > len(ans):

       ans = s[i:j]

print(ans)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите сегодня на языке python Совпадающие начало и конец Дана строка. Требуется найти самую длинную её подстроку, у которой совпадает первый и последний символы. Если подходит несколько подстрок, то выведите любую из них. Входные данные На вход подаётся одна строка из строчных латинских букв длиной не более 100 символов. Выходные данные Выведите ответ на задачу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

libirishka7910
iriska-669
dashafox8739
tarrin-ka
webotryvclub21
Kalashnikova
Юлия Соколовская1568
Zheleznyakova
AnvarzhonovichNadezhda1071
Tsibrova
ElenaEgorova1988576
Galinova2911
Болеславовна
ПодлеснаяМакарова1883
marinaled8187