Поделитесь своими знаниями, ответьте на вопрос:
C ++ Уникальные элементы Дан массив. Распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. Элементы следует распечатывать в том порядке, в котором они встречаются в массиве. Создавать новые массивы нельзя. Входные данные В первой строке входных данных содержится натуральное число n (n≤100) — количество элементов массива. В следующей строке содержится n натуральных чисел, не превосходящих 30000 — элементы массива. Выходные данные Выведите ответ на задачу.
#include <iostream>
#include <vector>
using namespace std;
int main()
{
int n;
cin >> n;
vector<int> v(n);
for (int i = 0; i < n; ++i){
cin >> v[i];
}
for (int i = 0; i < n; ++i){
bool flag = false;
for (int j = 0; j < i; ++j){
if (v[i] == v[j]){
flag = true;
}
}
for (int j = i + 1; j < n; ++j){
if (v[i] == v[j]){
flag = true;
}
}
if (flag == false){
cout << v[i] << " ";
}
}
return 0;
}
Объяснение: