alina Korneev
?>

Питон ! Напишите программу которая получает два целых числа A и B и выводит квадраты всех чисел в интервале от A до B с шагом 1, 5 (сначала используя цикл while потом for)​

Информатика

Ответы

varvara82193
Program n1;
var
st: string;
i,c: longint;
b: boolean;
procedure numdig(st: string; x: char);
var i,k: longint;
t: string;
begin
t:='';
k := 0;
for i := 1 to length(st) do
begin
if st[i] = x then k := k + 1;
end;
if(k<>0) and (k<>1) then
begin
if(k=2) or (k=3) or (k=4) then t:='а';
writeln('цифра ',x,' повторяется ',k,' раз',t);
c:=c+1;
end
end;
begin
c:=0;
write('введите число: ');
read(i);
str(i, st);
numdig(st,'0');
numdig(st,'1');
numdig(st,'2');
numdig(st,'3');
numdig(st,'4');
numdig(st,'5');
numdig(st,'6');
numdig(st,'7');
numdig(st,'8');
numdig(st,'9');
if c=0 then writeln('цифры не повторяются');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Питон ! Напишите программу которая получает два целых числа A и B и выводит квадраты всех чисел в интервале от A до B с шагом 1, 5 (сначала используя цикл while потом for)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sinicin80
Каныбек698
Gainalii1912
leeteukism
dushechkin2
in-1973
iptsr4968
Равиль_Евгеньевич1808
2 толка 2 задание помагите
elvini857
gubernatorov00
Valentina1520
dvpered
myatadinamo
alesia1986
okison2847