Поделитесь своими знаниями, ответьте на вопрос:
С++ Удаление элемента Удалите из массива элемент в индексом k. Обратите внимание, считывание и вывод массива уже написаны за вас, необходимо написать только фрагмент программы — само удаление элемента. Входные данные В первой строке задано натруальное число n (n≤100) и индекс k (0≤k #include using namespace std; int main() { int n, k; cin >> n >> k; vector A(n); for (int i = 0; i < A.size(); i++) { cin >> A[i]; } for (int i = 0; i < A.size(); ++i){ cout << A[i] << " "; } cout << endl; return 0; } между строками кода надо дописать код
procedure Convert(V:array of integer);
begin
for var i:=0 to V.Length-1 do
if V[i]>9 then V[i]:=9
else
if V[i]<5 then V[i]:=5
end;
procedure Develop(c:char; k:integer);
begin
WritelnFormat('*** Массив {0} ***',c);
var a:=ArrRandom(k,-5,15);
Write('исходный : '); a.PrintLn(',');
Convert(a);
Write('результат: '); a.PrintLn(',');
end;
begin
var m:=ReadInteger('Количество элементов в массиве A:');
var n:=ReadInteger('Количество элементов в массиве B:');
Develop('A',m);
Develop('B',n)
end.
Тестовое решение:
Количество элементов в массиве A: 15
Количество элементов в массиве B: 10
*** Массив A ***
исходный : 6,5,-5,9,1,0,-3,9,13,12,-4,8,11,14,-5
результат: 6,5,5,9,5,5,5,9,9,9,5,8,9,9,5
*** Массив B ***
исходный : 5,12,12,4,7,9,7,-3,-1,-2
результат: 5,9,9,5,7,9,7,5,5,5