burylin9
?>

Наименьший положительныйВыведите значение наименьшего из всех положительных элементов в массиве. Известно, что в массиве есть хотя бы один положительный элемент.Входные данныеВ первой строке содержится натуральное число n (n≤100) — количество элементов в массиве. В следующей строке содержатся n чисел — элементы массива. Гарантируется, что значения всех элементов — целые числа, не превосходящие 100 по абсолютному значению.Выходные данныеВыведите ответ на задачу.

Информатика

Ответы

Nikolaevich

Ниже приведен вариант, когда программа запустится, но не выполнится:

program Zadacha;  // удален символ 1

var a, b, c, d, s, p, r, q: integer;

begin // began заменен на begin

write (‘Ведите первое число=’, a); // В конце вместо , должно быть ;

writeln (‘Ведите второе число=’, b);// В конце вместо , должно быть ;

writeln (‘Ведите третье число=’, c);// В конце вместо , должно быть ;

writeln (‘Ведите четвертое число=’, d);

s:=a+b+c+d;

p:=a*b*c*d;

r:=a-b-c-d;

q:=a div b;

writeln ('Сумма=',s);

writeln ('Произведение=',p);

write ('Разность=',r);

write ('Частное=',q)

end.

Чтобы программа выполнялась нормально, нужно изменить ее следующим образом:

program Zadacha;

var a, b, c, d, s, p, r, q: integer;

begin

write ('Ведите первое число='); read(a);

writeln ('Ведите второе число='); read(b);

writeln ('Ведите третье число='); read(c);

writeln ('Ведите четвертое число='); read(d);

s:=a+b+c+d;

p:=a*b*c*d;

r:=a-b-c-d;

q:=a div b;

writeln ('Сумма=',s);

writeln ('Произведение=',p);

write ('Разность=',r);

write ('Частное=',q)

end.

Также остается неясным, что подразумевалось под "разностью" и "частным". Если "разностью" еще можно назвать выражение a-b-c-d, то a/b - точно не частное. Это только целая часть от деления a на b. Чтобы это было частным, нужно переменную q объявить как real:

program Zadacha;

var a, b, c, d, s, p, r: integer;

var q: real;

begin

...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Наименьший положительныйВыведите значение наименьшего из всех положительных элементов в массиве. Известно, что в массиве есть хотя бы один положительный элемент.Входные данныеВ первой строке содержится натуральное число n (n≤100) — количество элементов в массиве. В следующей строке содержатся n чисел — элементы массива. Гарантируется, что значения всех элементов — целые числа, не превосходящие 100 по абсолютному значению.Выходные данныеВыведите ответ на задачу.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

КириллЕгорова1906
av52nazarov
Mariya694
zsv073625
ivanlimeexpo
inulikb
cheberyako2013
gullieta
bar02
dmtr77
Вишняков997
vmnk38
Yelfimova-andrei
pryvalovo48
Екатерина1979