?>
На Python нужно сделать: "Напишите программу, которая получает с клавиатуры трёхзначное число. В результате работы программа выводит на экран все числа (каждое на новой строке), которые получены в результате перестановки цифр исходного числа."
Ответы
var
a, b, c, s: real;
begin
Writeln('Вычислите S поверхности параллелепипеда.');
Writeln('Введите исходные данные:');
Write('Длина(см)? '); Readln(a);
Write('Ширина(см)? '); Readln(b);
Write('Высота(см)? '); Readln(c);
s := 2 * (a * b + b * c + c * a);
Writeln('Площадь поверхности: ', s, ' кв.см.')
end.
Тестовое решение:
Вычислите S поверхности параллелепипеда.
Введите исходные данные:
Длина(см)? 9
Ширина(см)? 7.5
Высота(см)? 5
Площадь поверхности: 300 кв.см.
program p2;
var
ct,ck,s:real;
kt,kk:integer;
begin
Writeln('Вычисление стоимости покупки');
Writeln('Введите исходные данные:');
Write('Цена тетради(руб.)? '); Readln(ct);
Write('Количество тетрадей? '); Readln(kt);
Write('Цена карандашей(руб.)? '); Readln(ck);
Write('Количество карандашей? '); Readln(kk);
s:=ct*kt+ck*kk;
Writeln('Стоимость покупки: ',s:0:2,' руб.')
end.
Тестовое решение:
Вычисление стоимости покупки
Введите исходные данные:
Цена тетради(руб.)? 2.75
Количество тетрадей? 5
Цена карандашей(руб.)? 0.85
Количество карандашей? 2
Стоимость покупки: 15.45 руб.