girra
?>

3. Используя цикл «for», написать программу на языке С++ для решения следующей зада-чи: Среди всех двузначных чисел найти количество таких, у которых удвоенное произ-ведение цифр кратно 3. Например, у числа 23 удвоенное произведение цифр 2*(2*3) = 18, т.е. кратно 3, а у числа 25 удвоенное произведение цифр 2*(2*5) = 20 не кратно 3. Определите, сколько чисел удо-влетворяет задаче

Информатика

Ответы

oserdyuk41

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int i, kol = 0;;

   for(i = 10; i < 99; i++){

       if( (2 * ((i % 10) * (i /10))) % 3 == 0){

           ++kol;

       }

   }

   cout<<"Количество чисел: "<<kol<<endl;

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

3. Используя цикл «for», написать программу на языке С++ для решения следующей зада-чи: Среди всех двузначных чисел найти количество таких, у которых удвоенное произ-ведение цифр кратно 3. Например, у числа 23 удвоенное произведение цифр 2*(2*3) = 18, т.е. кратно 3, а у числа 25 удвоенное произведение цифр 2*(2*5) = 20 не кратно 3. Определите, сколько чисел удо-влетворяет задаче
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Каныбек698
Isaeva_Marin1010
oalexandrova75
Darialaza
zotcet7
veravlad
rudakovam198
stratocasterr34
dushechkin2
marinatehnomaster21
vodexshop2
dvpered
vantoslaltd
Сергеевич1907
Gainalii1912