uvarovig
?>

Написать программу в PascalABC.net:У трёх 6-значных чисел найти:- произведение нечётных цифр

Информатика

Ответы

Viktoriya

var

pr1,pr2,pr3,a,b,c : integer;

begin

readln(a,b,c);

a := abs(a);

b := abs(b);

c := abs(c);

pr1 := 1;

pr2 := 1;

pr3 := 1;

while (a > 0) and (b > 0) and (c > 0) do

begin

if (a mod 10)mod 2 <> 0 then

pr1 := pr1 * (a mod 10);

a := a div 10;

if (b mod 10)mod 2 <> 0 then

pr2 := pr2 * (b mod 10);

b := b div 10;

if (c mod 10)mod 2 <> 0 then

pr3 := pr3 * (c mod 10);

c := c div 10;

end;

writeln(pr1,' ', pr2,' ',pr3);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в PascalABC.net:У трёх 6-значных чисел найти:- произведение нечётных цифр
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Georgievich-Zamudinovna2003
Anna572
Playintim405374
misie1974
znaberd786
chizhenkovd9
familumid
mail66
lider-mpl550
inessa12006
leonid-adv70
sodrugestvo48
svo1961
Veril8626
Akvamontaz