KononovaMaiorov453
?>

Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наименьшая

Информатика

Ответы

cherkashenko87543

from random import randint

n, m = 5, 5

A = [[randint(1, 10) for j in range(m)] for i in range(n)]

for row in A:

 for x in row:

   print("{:4d}".format(x), end='')

 print()

b = [sum(x) for x in zip(*A)]

 

print('Суммы по столбцам')

print(b)

k = b.index(min(b))

print('Индекс столбца с наименьшей суммой : ', k)

print('----------------')

for i in range(m) :

 print(A[i][k])


Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наимен

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой наименьшая
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

puchkovajulia
Oksana-Kirakosyan1301
Liliya-buc
alexseyzyablov
Nikolai710
Gennadievna bessonov
RozaAsadullina
verkop9
Валентинович133
Leonidovich_Elena771
reception
Жуков219
uvarovig
Татьяна902
Chuhnin195107364