?>
Python Задача: Математики и грибы(Время: 1 сек. Память: 16 Мб : 100)Однажды два математика пошли в лес собирать грибы. Час шли, два шли, а потом вдруг остановились и решили выяснить: кто из них набрал грибов больше? Достали они весы (какой же математик пойдет в лес без весов?) и взвесили свои корзины с собранным урожаем, а потом записали полученные числа a1 и b1 на листочек, но этих данных оказалось недостаточно, т.к. массы корзин математиков были им неизвестны. Поэтому второй математик пересыпал все грибы в корзину к первому (полностью опустошив свою корзину), и они снова взвесили свои корзины, получив числа a2 и b2 соответственно. Наконец, первый математик пересыпал все грибы в корзину ко второму (полностью опустошив свою корзину); после взвешивания они получили числа a3 и b3 соответственно. Этих данных оказалось уже достаточно для определения победителя, и довольные математики пошли дальше.Вам же предстоит вычислить массу грибов в корзине каждого из математиков до совершения всех пересыпаний.Входные данныеВходной файл INPUT.TXT содержит три строки, в каждой из которых располагаются 2 натуральных числа – результаты взвешивания корзин математиков на каждом из этапов соответственно. Известно, что массы корзин при взвешиваниях не превосходили 3∙1018.Выходные данныеВ выходной файл OUTPUT.TXT выведите пару целых чисел через пробел – массы грибов, которые собрал каждый из математиков соответственно.в чем моя ошибка :a, b = map(int, input( split())print( a[0]-a[2], b[0]-b[1] )пишет что слишком долго...
Ответы
Следовательно, нужно проверить, выполняется ли это тождество для заданных координат.
В этом тождестве есть одна неприятная вещь: если y₂=y₁ и/или x₂=x₁, то в знаменателе получается ноль, чему компьютер уж точно не обрадуется. Поэтому такой случай надо рассмотреть отдельно, исходя из геометрического смысла.
Если же y₂≠y₁ и x₂≠x₁, можно привести тождество к более удобному виду:
Поскольку координаты могут быть и не целыми, а такие нецелые ("вещественные") числа представляются в компьютере с ограниченной точностью, тождество может оказаться ложным по причине такой неточности. Для обхода такого случая будем полагать, что два значения равны друг-другу, если их разность по модулю не превышает некоторой малой величины, т.е.:
Вернемся к случаю y₂=y₁. В этом случае прямая параллельна оси Х, т.е. тогда условием принадлежности третьей точки данной прямой будет y₃=y₁ при любом х. То же можно сказать и про случай х₂=х₁, когда следует проверить, что х₃=х₁.
Если все три точки лежат на одной прямой, то у средней из них значение любой из координат должно находиться между значениями двух одноименных координат крайних точек.
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
var
x1,y1,x2,y2,x3,y3,p1,p2:real;
on_line:boolean;
begin
// Без проверки считаем, что у двух любых точек
// не может быть одинаковых координат
Write('Координаты точки А: '); Read(x1,y1);
Write('Координаты точки B: '); Read(x2,y2);
Write('Координаты точки C: '); Read(x3,y3);
if x3=x1 then on_line:=(x2=x1);
if (not on_line) then
if y3=y1 then on_line:=(y2=y1);
if not on_line then begin
p1:=(x3-x1)/(x2-x1); p2:=(y3-y1)/(y2-y1);
on_line:=(abs(p1-p2)<1e-8)
end;
if on_line then begin
Writeln('Точки лежат на одной прямой');
if (x2>x1) and (x2<x3) or (x2>x3) and (x2<x1)
then Writeln('Точка B внутри')
else
if (x3>x1) and (x3<x2) or (x3>x2) and (x3<x1)
then Writeln('Точка C внутри')
else
Writeln('Точка A внутри')
end
else
Writeln('Точки не лежат на одной прямой')
end.
Тестовое решение:
Координаты точки А: 1 2.5
Координаты точки B: 3 3.5
Координаты точки C: -4 0
Точки лежат на одной прямой
Точка A внутри