Сурат1199
?>

Напишите программу на с++ без динамических массивов с функцией Наименьшее общее кратное (НОК) двух натуральных чисел – это наименьшее число, которое делится нацело на оба исходных числа. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию. Входные данные Входная строка содержит два натуральных числа, разделённые пробелом – a и b . Выходные данные Программа должна вывести одно натуральное число: НОК заданных чисел.

Информатика

Ответы

annakuzina2023

надеюсь правильно

Объяснение:

#include <iostream>

using namespace std;

int gcd(int a, int b) {

   return (a == 0) ? b: gcd(b % a, a);

}

 

int main() {

   int n, m = 0;

   cin >> n;

   for (int i = 0; i < n; i++) {

       int a;

       cin >> a;

       m = gcd(m, a);

   }

   cout << m;

   return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на с++ без динамических массивов с функцией Наименьшее общее кратное (НОК) двух натуральных чисел – это наименьшее число, которое делится нацело на оба исходных числа. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию. Входные данные Входная строка содержит два натуральных числа, разделённые пробелом – a и b . Выходные данные Программа должна вывести одно натуральное число: НОК заданных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bolshakova Shigorina
Вера1072
s9152992722344
vladislavk-market2
utburt
Максим_Нина
reznikvi
elbabitch2014
pryvalovo48
Litvin_Ivanov
Дарья16
Panei
karpovaveronika196
iv1as2
zmlavra