aluka
?>

- 1) написать конспект в тетрадях, что такое двумерный массив и как его записать в паскале. 2)В тетрадях написать программу нахождения суммы, количества отрицательных, min, max элементов в двумерном массиве, с размерностью 3 на 3, который сформирован из диапазона от -10 до 20.

Информатика

Ответы

Рожнов
#include <iostream>
#include <list>

using namespace std;

int main() {
    list<int>mylist;
    //Делаем со списком, что хотим
    mylist.push_back(1);
    mylist.push_back(2);
    mylist.push_back(3);
    mylist.push_back(-4);
    mylist.push_back(5);
    for (auto i : mylist) {
        cout << i << " ";
    }
    cout << "\n";
    //Удаляем последний отрицательный элемент
    auto it = mylist.end();
    while (*it > 0) {
        if (it == mylist.begin()) {
            cout << "Not found.\n";
            return 0;
        }
        it--;
    }
    //Делаем со списком, что хотим
    mylist.erase(it);
    for (auto i : mylist){
        cout << i << " ";
    }
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

- 1) написать конспект в тетрадях, что такое двумерный массив и как его записать в паскале. 2)В тетрадях написать программу нахождения суммы, количества отрицательных, min, max элементов в двумерном массиве, с размерностью 3 на 3, который сформирован из диапазона от -10 до 20.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

infosmolenskay
Алексей Ксения
Belokonev286
MelnikovaIvanovna
ur101679
АртакСергеевич1723
irschacha
girra
abuley
Егорова
Chitaia
andreyduborezz2913
vlrkinn
alenkadon6
Игорь Андрей