Тинчурина1528
?>

1) Напишите программу, которая с цикла подсчитывает сумму всех четных чисел от 5 до 25. Можете подсказать, где здесь ошибка? #include using namespace std;void chislo (int i, int summa=0){ if (i%2==0) { summa=summa+i; }}int main (){ int i=5; i<=25; i++; int summa; cout<<"summa vseh chetnih chisel="< return 0;}

Информатика

Ответы

Теплова

Короче, с выводом не очень понял, поэтому будет 4 варианта, выбери сам

Обязательная часть программы:

import datetime

year, month, day = int(input('Введите год: ')), int(input('Введите месяц: ')), int(input('Введите день: '))

date = datetime.date(year, month, day)

delta = datetime.timedelta(days=1)

date = str(date + delta).split('-')[::-1]

Тут нужно выбрать одну из строк, будем рассматривать на примере 31 декабря 2019 года(то, что стоит после решетки и саму решетку не копируй:

Вариант 1:

print(*date)     # 01 01 2020  --- это вывод(обычный)

Вариант 2:

print(int(date[0]), int(date[1]), date[2])    # 1 1 2020 (без ведущих нулей)

Вариант 3:

print(str(int(date[0])) + str(int(date[1])), date[2]) #11 2020(без нулей и пробелов)

Вариант 4:

print(str(date[0]) + str(date[1]), date[2])      # 0101 2020(без пробелов)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) Напишите программу, которая с цикла подсчитывает сумму всех четных чисел от 5 до 25. Можете подсказать, где здесь ошибка? #include using namespace std;void chislo (int i, int summa=0){ if (i%2==0) { summa=summa+i; }}int main (){ int i=5; i<=25; i++; int summa; cout<<"summa vseh chetnih chisel="< return 0;}
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

rb-zakaz
kotocafe45
baranova302
myrisik2490
igor-790
alvs9
ivan-levermor
Mashkov-Daniil1764
алексеевич810
Александрович Андреевна
Bologova Golovach1989
agitahell149
Novikova Aleksandrovna
Avdimov5
baron