Поделитесь своими знаниями, ответьте на вопрос:
Задача B Светошоу Тип задачи: Максимальное время работы на одном тесте: Максимальный объем используемой памяти: Максимальная оценка: За каждую дополнительную попытку: Задача по программированию 2 секунды 64 мегабайта 10 штрафных Юный хакер Павловкин просто обожал систему умного дома RazanСleverHome3000, которую установили его родители. Система была невероятно умна и обладала широким функционалом, но больше всего Павловкина привлекала возможность включать и выключать свет в любой из N комнат его квартиры. Конечно, родители не разрешали ему баловаться с освещением, и на панели управления домом всегда стоял сложный пароль. Впрочем, сложности пароля не хватило, чтобы остановить Павловкина, и он всё же получил полный доступ к системе. Теперь, юный гений хочет воплотить в реальность давно запланированное им светошоу. Светошоу состоит из M последовательно выполняемых действий, каждое из которых представляет из себя либо включение, либо выключение света в какой-нибудь комнате (не важно, какой Шоу сорвётся и Павловкину станет очень грустно, если в какой-то момент окажется, что ему пора включить свет в какой-то комнате, а во всех комнатах он уже горит, или, наоборот, если ему нужно будет потушить свет, а во всех комнатах уже темно. Поэтому, он просит вас ему и написать программу, которая проверит, сможет ли он довести своё шоу до конца. Родители Павловкина — люди экономные, поэтому в начале шоу свет во всех комнатах выключен. Формат входных данных В первой строке входных данных вводятся два числа N и M (1 ≤ N, M ≤ 10000) — количество комнат в квартире Павловкина и количество действий в светошоу соответственно. В следующих M строках содержатся команды двух видов: ● «Lights up» — включить свет в какой-нибудь комнате ● «Lights out» — выключить свет в какой-нибудь комнате Формат выходных данных Ваша программа должна вывести единственную строку «Yeah», если Павловкин сможет довести своё шоу до конца и «No way», если это невозможно. Пример Пример входных данных Пример выходных данных 26 Lights up Lights up Lights out Lights up Lights out Lights out Yeah
[any] Pascal: (без хранения введённых чисел => "эффективная")
var a, i, x: integer; begin for i := 1 to 6 do begin read(a); if a>0 then x := x + 1 else if a<0 then x := x - 1 end; if x>0 then write('Больше положительных') else if x<0 then write('Больше отрицательных') else write('Одинаково')end.PascalABC.NET: (с хранением введённых чисел в массиве)
## var a := ReadArrInteger(6); var x := a.Sum(x -> x>0 ? 1 : -1); if x=0 then Write('Одинаково') else Print('Больше', x>0 ? 'положительных' : 'отрицательных')Пример работы: