ЕленаГерасимова
?>

РЕШЕНИЕ НУЖНО ТОЛЬКО НА PYTHON: Рассматривается множество целых чисел, принадлежащих числовому отрезку (2807; 8558), которые удовлетворяют следующим условиям: - запись в двоичной системе заканчивается на 11; - запись в девятеричной системе заканчивается на 5. Найдите максимальное из таких чисел и их сумму. Гарантируется, что искомая сумма не превосходит 10^7

Информатика

Ответы

Yuliya1693
Const N = 10;

begin
  var a: array[1..N] of real;
  var i: integer;
  var growing: boolean;
 
  for i := 1 to N do begin
    readln(a[i]);
  end;
 
  growing := true;
 
  for i := 2 to N do begin
    if a[i] <= a[i - 1] then begin
      growing := false;
      break;
    end;
  end;
 
  writeln(growing);
end.

const m = 5;
const n = 4;
const limit = 100;

begin
  var matrix: array[1..m] of array[1..n] of real;
  var matrixb: array[1..m - 1] of array[1..n - 1] of real;
  var row, col, rb, cb, lowest_row, lowest_col: integer;
  var lowest: real;
  var p: boolean;
 
  lowest := limit;
 
  for row := 1 to m do begin
    for col := 1 to n do begin
      matrix[row][col] := random(limit - 1);
      if matrix[row][col] < lowest then begin
        lowest := matrix[row][col];
        lowest_col := col;
        lowest_row := row;
      end;
      write(matrix[row][col], ' ');
    end;
    writeln('');
  end;
 
  writeln('');
  writeln(lowest);
  writeln('');
 
  rb := 1;
 
  for row := 1 to m do begin
    p := false;
    cb := 1;
    for col := 1 to n do begin
      if (not (col = lowest_col)) and (not (row = lowest_row)) then begin
        p := true;
        matrixb[rb][cb] := matrix[row][col];
        cb := cb + 1;
      end;
    end;
    if p then begin
      rb := rb + 1;
    end;
  end;
 
  for rb := 1 to m - 1 do begin
    for cb := 1 to n - 1 do begin
      write(matrixb[rb][cb], ' ');
    end;
    writeln('');
  end;
 
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

РЕШЕНИЕ НУЖНО ТОЛЬКО НА PYTHON: Рассматривается множество целых чисел, принадлежащих числовому отрезку (2807; 8558), которые удовлетворяют следующим условиям: - запись в двоичной системе заканчивается на 11; - запись в девятеричной системе заканчивается на 5. Найдите максимальное из таких чисел и их сумму. Гарантируется, что искомая сумма не превосходит 10^7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

А Дзукаев1562
Olgera1
andreykrutenko
andreanikin
alenchik19938823
infoproletarskay745
annanudehead1426
Нескажу25
sveta300856729
Chuhnin195107364
ooottdi
VladimirovnaSimonov
langprint
Лихачев Полина1978
minaskorolev8