cmdkotelniki
?>

На вход приведённой ниже программе поступает строка, начинающаяся с символа «>», а затем содержащая 20 цифр 1 , 20 цифр 2 и 20 цифр 3 , расположенных в произвольном порядке. Сколько цифр 1 будет в строке, которая получится после выполнения данной программы? НАЧАЛО ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>3) ЕСЛИ нашлось (>1) ТО заменить (>1, 222>) КОНЕЦ ЕСЛИ ЕСЛИ нашлось (>2) ТО заменить (>2, >3) КОНЕЦ ЕСЛИ ЕСЛИ нашлось (>3) ТО заменить (>3, 11>) КОНЕЦ ЕСЛИ КОНЕЦ ПОКА КОНЕЦ

Информатика

Ответы

Soliyabronzoni
Program Diagonal;
uses Crt;
const n = 5;
Type Mas = array [1..n, 1..n] of integer;
       Vec = array [1..n*n] of integer;
var A: Mas;
     V: Vec;
     i, j , k: integer;
     p : longint;
begin
 ClrScr;
 Randomize;
 p:=1;
 WriteLn('Massiv A:');
 for i:=1 to n do
   begin
      for j:= 1 to n do
         begin
           A[i, j]:= 1+random (9);
           p:=p*A[i,i];
           Write(A[i, j]:4);
         end;
   WriteLn; WriteLn;
   end;
k:=0;
for i:=1 to n do
  for j:=1 to n do
      begin
        if (A[i,j]>p) and (j<i) then
          begin
            k:=k+1;
           V[k]:=A[i, j];
          end;
      end;
  WriteLn('Vector V=');
  for j:=1 to k do
     Write(V[j]:4);

  WriteLn;
  if k=0 then Writeln ('None');
ReadLn;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход приведённой ниже программе поступает строка, начинающаяся с символа «>», а затем содержащая 20 цифр 1 , 20 цифр 2 и 20 цифр 3 , расположенных в произвольном порядке. Сколько цифр 1 будет в строке, которая получится после выполнения данной программы? НАЧАЛО ПОКА нашлось (>1) ИЛИ нашлось (>2) ИЛИ нашлось (>3) ЕСЛИ нашлось (>1) ТО заменить (>1, 222>) КОНЕЦ ЕСЛИ ЕСЛИ нашлось (>2) ТО заменить (>2, >3) КОНЕЦ ЕСЛИ ЕСЛИ нашлось (>3) ТО заменить (>3, 11>) КОНЕЦ ЕСЛИ КОНЕЦ ПОКА КОНЕЦ
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ka2ffka141
zubareva23338
jaksonj326
helenavalenti2846
Стародубцева_Васильевич485
Amelin-Alipova
solonataly5
Aleksandr-Andrei
a8227775
kmr495270
Shamsulo
vbnm100584
hotnuts
masha812