fiorire731
?>

Напишите программу, которая находит в матрице строку с минимальной суммой. Если таких строк несколько, найдите первую такую строку. (C++ CIN COUT ) без new *int

Информатика

Ответы

orion-inginiring7807
//Dev-C++ 5.11

#include <iostream>
using namespace std;

int main(void)
 {const int n=3;
 const int m=3;
 int ma[n][m];
 int c;
 cout<<"First matrix"<<endl;
 for(int i=0;i<n;i++)
  {for(int j=0;j<m;j++)
   {ma[i][j]=i+j;
   cout<<ma[i][j]<<" ";}
  cout<<endl;}
 for(int i=0;i<n/2;i++){
  for(int j=0;j<m;j++)
   {c=ma[i][j];
   ma[i][j]=ma[n-i-1][j];
   ma[n-1-i][j]=c;}}
 cout<<"Final matrix"<<endl;
 for(int i=0;i<n;i++)
  {for(int j=0;j<m;j++)
   cout<<ma[i][j]<<" ";
  cout<<endl;}
 return 0;
}

Пример работы программы(n=3,m=3):
First matrix:
0 1 2
1 2 3
2 3 4
Final matrix:
2 3 4
1 2 3
0 1 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая находит в матрице строку с минимальной суммой. Если таких строк несколько, найдите первую такую строку. (C++ CIN COUT ) без new *int
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

av4738046
ignashkinamasha
Levinalx4938
troian07
artem-dom
sergeev-alp5
laleonaretouch
saryba
Елена-Семенова
Anna Artem
maxborod
АлександрАлина
Назаров588
skalegin68
a-lossev111