IrinaSolodukhina1495
?>

Задача 2. Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями , кроме умножения получить : а в 20 степени за 5 операций

Информатика

Ответы

azarov8906

class Student():

   def __init__(self, name, adress, klass, profile, subj, raiting, teacher):

       self.name = name

       self.adress = adress

       self.klass = klass

       self.profile = profile

       self.subj = subj

       self.raiting = raiting

       self.teacher = teacher

   def print_info(self):

       print('Ім\'я учня:', self.name)

       print('Адресс:', self.adress)

       print('Класс:', self.klass)

       print('Профіль', self.profile)

       print('Предмет:', self.subj)

       print('Оцфнка:', self.raiting)

       print('Вчитель:', self.teacher, '\n')

artemenko_inf = Student('Артеменко О.П.', 'м. Київ, вул. Солом\'янська, 1', '10А', 'Гуманітарій', 'Інформатика', '10', 'Іванов І.А.')

artemenko_ukr = Student('Артеменко О.П.', 'м. Київ, вул. Солом\'янська, 1', '10А', 'Гуманітарій', 'Укр. мова', '9', 'Жук А.О.')

artemenko_fiz = Student('Артеменко О.П.', 'м. Київ, вул. Солом\'янська, 1', '10А', 'Гуманітарій', 'Фізика', '7', 'Король О.А.')

artemenko_inf.print_info()

artemenko_ukr.print_info()

artemenko_fiz.print_info()

koben_algeb = Student('Кобен С.К.', 'м. Київ, вул. Тичини, 12', '10Б', 'Фізико-математичний', 'Алгебра', '12', 'Пиріг О.Л.')

koben_inf = Student('Кобен С.К.', 'м. Київ, вул. Тичини, 12', '10Б', 'Фізико-математичний', 'Інформатика', '10', 'Іванов І.А.')

koben_ukr = Student('Кобен С.К.', 'м. Київ, вул. Тичини, 12', '10Б', 'Фізико-математичний', 'Укр. мова', '10', 'Повх А.К.')

koben_algeb.print_info()

koben_inf.print_info()

koben_ukr.print_info()

morbls_chem = Student('Морись П.З.', 'м. Київ, вул. Вишнева, 3', '10А', 'Гуманітарій', 'Хімія', '10', 'Заєць А.В.')

morbls_chem.print_info()

Объяснение:

я создал класс "ученик", с именем адресом и т.д., и потом создал переменные, которым присвоил класс "ученик" и вывел информацию о них

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача 2. Составить программу, решающую следующую задачу: Дано число а. Не пользуясь никакими другими операциями , кроме умножения получить : а в 20 степени за 5 операций
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

romka1210
tofilev
angelina-uj1350
сергеевич1958
Shishkinaanasta1997
SAMSCHOOL96
kogakinoa
kulikovtsud
Мария591
ivanjeka87
beglovatatiyana
ivanrancev
хаджимурод1172
ИНФОРМАТИКА ВО ВО ВЛОЖЕНИИ
rebet61
kassel1b