krimenu5033
?>

Python! Покупка билетов За билетами на премьеру нового мюзикла выстроилась очередь из N человек, каждый из которых хочет купить 1 билет. На всю очередь работала только одна касса, поэтому продажа билетов шла очень медленно, приводя «постояльцев» очереди в отчаяние. Самые сообразительные быстро заметили, что, как правило, несколько билетов в одни руки кассир продаёт быстрее, чем когда эти же билеты продаются по одному. Поэтому они предложили нескольким подряд стоящим людям отдавать деньги первому из них, чтобы он купил билеты на всех. Однако для борьбы со спекулянтами кассир продавала не более 3 билетов в одни руки, поэтому договориться таким образом между собой могли лишь 2 или 3 подряд стоящих человека. Известно, что на продажу i-му человеку из очереди одного билета кассир тратит Ai секунд, на продажу двух билетов — Bi секунд, трёх билетов — Ci секунд. Напишите программу, которая подсчитает минимальное время, за которое могли быть обслужены все покупатели. Обратите внимание, что билеты на группу объединившихся людей всегда покупает первый из них. Также никто в целях ускорения не покупает лишних билетов (то есть билетов, которые никому не нужны Входные данные На вход программы поступает сначала число N — количество покупателей в очереди (1≤N≤5000). Далее идут N троек натуральных чисел Ai, Bi, Ci. Каждое из этих чисел не превышает 3600. Люди в очереди нумеруются, начиная от кассы. Выходные данные Требуется вывести одно число — минимальное время в секундах, за которое могли быть обслужены все покупатели. Примеры Ввод 5 5 10 15 2 10 15 5 5 5 20 20 1 20 1 1 Вывод 12

Информатика

Ответы

AnnaChulyukanova3

Пример на Паскале. Пусть массив размером 100 элементов

Program Maasiv;

var A:array[1..100] of real; i,s:integer; k :real;

begin

random;

For i:=1 to 100 do A[i]:=randomize(100)-50; {заполняем массив случайными числами от -50 до 50}

s:=0; for i:=1 to 100 do if A[i]<i then S:=S+A[i]; writeln(s);{задание а}

s:=0; for i:=1 to 100 do if i/2=int(i/2) then S:=S+A[i]; writeln(s);{задание б}

s:=0; for i:=1 to 100 do if A[i]<0 then S:=S+A[i]; writeln(s);{задание в}

readln(k);s:=0; for i:=1 to 100 do if A[i]>k then S:=S+A[i]; writeln(s);{задание г}

end.

 

 

 

 

 

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python! Покупка билетов За билетами на премьеру нового мюзикла выстроилась очередь из N человек, каждый из которых хочет купить 1 билет. На всю очередь работала только одна касса, поэтому продажа билетов шла очень медленно, приводя «постояльцев» очереди в отчаяние. Самые сообразительные быстро заметили, что, как правило, несколько билетов в одни руки кассир продаёт быстрее, чем когда эти же билеты продаются по одному. Поэтому они предложили нескольким подряд стоящим людям отдавать деньги первому из них, чтобы он купил билеты на всех. Однако для борьбы со спекулянтами кассир продавала не более 3 билетов в одни руки, поэтому договориться таким образом между собой могли лишь 2 или 3 подряд стоящих человека. Известно, что на продажу i-му человеку из очереди одного билета кассир тратит Ai секунд, на продажу двух билетов — Bi секунд, трёх билетов — Ci секунд. Напишите программу, которая подсчитает минимальное время, за которое могли быть обслужены все покупатели. Обратите внимание, что билеты на группу объединившихся людей всегда покупает первый из них. Также никто в целях ускорения не покупает лишних билетов (то есть билетов, которые никому не нужны Входные данные На вход программы поступает сначала число N — количество покупателей в очереди (1≤N≤5000). Далее идут N троек натуральных чисел Ai, Bi, Ci. Каждое из этих чисел не превышает 3600. Люди в очереди нумеруются, начиная от кассы. Выходные данные Требуется вывести одно число — минимальное время в секундах, за которое могли быть обслужены все покупатели. Примеры Ввод 5 5 10 15 2 10 15 5 5 5 20 20 1 20 1 1 Вывод 12
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Филиппович_Николаевич
Смирнов-Оськина
vladburakoff5
Марина1101
Natalya1895
ЮлияДаниил520
Elen-ti81459
extremhunter
Vladimirovna1370
vapebroshop
mlf26
antrotip
Shtorm-Shoe
kristina1989
Sergei_Olga658