yaudo47
?>

Решите с pascal 1. Найти сумму чисел, которые оканчиваются на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. 2. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. 3. Пользователь вводит два целых числа A и B (А 4. Даны натуральные числа от 101 до 321. Напечатать те из них, которые делятся БЕЗ ОСТАТКА на 4, но не делятся на 6.

Информатика

Ответы

Lerkinm

1)

var

n,x,s,i : integer;

begin

s:=0;

write('Введите n: '); read(n);

for i:=1 to n do

begin

write('X - ', i, ' = '); read(x);

if x mod 10 = 9 then

s:=s+n;

end;

writeln('Сумма с 9 на конце = ', s);

end.

2)

var

n,i,max,x : integer;

begin

max:=0;

write('Введите n: '); read(n);

for i:=1 to n do

begin

if (x > max) and (x mod 5 = 0) then

max:=x;

write('X - ',i,' = '); read(x);

end;

writeln('Максимальное, кратное 5 = ', max);

end.

3)

var

a,b,i : integer;

begin

write('a = '); read(a);

write('b = '); read(b);

for i:=a to b do

begin

if (i mod 4 = 0) and (i mod 6 <> 0) then

writeln(i);

end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите с pascal 1. Найти сумму чисел, которые оканчиваются на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. 2. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. 3. Пользователь вводит два целых числа A и B (А 4. Даны натуральные числа от 101 до 321. Напечатать те из них, которые делятся БЕЗ ОСТАТКА на 4, но не делятся на 6.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Горина
Елена_Зайкин1665
mail9
cafemgimo
hr2251
drontox1031
diana0720
Moroshkina-Aristova2011
moisalexx7
kortikov77
Стадник620
byfetvostochniy
kuhonka2021
Artyukhin545
npprang21