ver2bit
?>

решить задачу на ПИТОНЕ! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2. Кол. Чисел не превышает 1000. Программа должна вывести одно число - максимальное число, оканчивающееся на 2

Информатика

Ответы

Маркина Ворошилина

import random

mass = []

masscomp = []

max = 0

for i in range(0, 1000):

   mass.append(random.randint(0, 1000000))

   masscomp = [int(x) for x in str(mass[i])]

   if (mass[i] > max and masscomp[len(masscomp) - 1] == 2):

       max = mass[i]

print(max)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

решить задачу на ПИТОНЕ! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2. Кол. Чисел не превышает 1000. Программа должна вывести одно число - максимальное число, оканчивающееся на 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Gatina
Galinagol559
rayon14
Jannadon77
zalev
Maksimova1320
Андрей_Станиславовна
mihalewanadia20176987
platonovkosty
banketvoshod
galinazajceva781
Verakravez8790
rstas
Anna-Miron
prokodasha