Vasileva
?>

Написать программу для решения задачи на Паскале. Дана строка, содержащая текст на русском языке: «Успех лидера вынашивается на плечах бегущих по пятам». В тексте необходимо заменить все символы «а» на «А». В отчет включить программный код на Паскале и результат работы программы в виде скриншота.

Информатика

Ответы

Александр
Var
  arr: array[1..27] of integer;
  summ: integer;
begin
  Randomize;
  for var i := 1 to 27 do
  begin
    arr[i] := random(-5, 5);
    summ := summ + arr[i];
  end;
  writeln('Массив: ',arr);
  writeln('Сумма всех элементов массива = ',summ);
  for var i := 1 to 27 do if arr[i] = 0 then arr[i] := summ;
  writeln('Массив: ',arr);
end.

пример работы:
Массив: [5,-1,1,5,4,-2,-3,0,3,5,-3,-4,3,0,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]
Сумма всех элементов массива = 14
Массив: [5,-1,1,5,4,-2,-3,14,3,5,-3,-4,3,14,-1,-4,5,-2,1,-4,5,2,-4,5,4,-5,-1]

var
  arr: array of integer;
  n,k,m: integer;
begin
  write('Введи n: ');
  readln(n);
  Randomize;
  arr:= new integer[n];
  for var i := 0 to n-1 do arr[i] := random(-5, 5);
  writeln('Массив: ',arr);
  for var i := 0 to n-1 do
  begin
    if arr[i]<0 then inc(k);
    if (i>=1) and (i<=6) then inc(m);
    if (i>=6) and (arr[i]>=0) then arr[i]:=1;
  end;
  writeln('Количество отрицательных элементов массива = ',k);
  writeln('Количество элементов массива в интервале [2..7] = ',m);
  writeln('Массив: ',arr);
end.

Пример работы:
Введи n: 5
Массив: [0,1,-4,1,3]
Количество отрицательных элементов массива = 1
Количество элементов массива в интервале [2..7] = 4
Массив: [0,1,-4,1,3]

Введи n: 15
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,3,1,-4,1,3]
Количество отрицательных элементов массива = 5
Количество элементов массива в интервале [2..7] = 6
Массив: [0,1,4,3,-3,5,-4,-1,1,-2,1,1,-4,1,1]

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для решения задачи на Паскале. Дана строка, содержащая текст на русском языке: «Успех лидера вынашивается на плечах бегущих по пятам». В тексте необходимо заменить все символы «а» на «А». В отчет включить программный код на Паскале и результат работы программы в виде скриншота.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vadim330
kifstd
Hugokate77729
pizniak
Дмитрий_Пергамент669
50 . логические выражения: 2, 4, 6, 8, 10
vvk2008
romolga3580
matoksana
kuznecovav3066
saltikovaK.S.1482
jakushkinn
viz-art-pnz1664
troian07
maximovpavel9114
Мельникова
▲