aregaa
?>

С++ ан массив из n элементов. Необходимо найти количество элементов массива, значения которых неотрицательны и меньше заданного числа A. Формат входных данных С клавиатуры вводится натуральное число n (n≤100 На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится единственное число A (0≤A≤100). Формат выходных данных В качестве ответа выведите единственное число — количество элементов, удовлетворяющих условию. входные данные 5 1 2 3 4 5 3 выходные данные 2

Информатика

Ответы

Вадим-Рашад323

int main()

{

size_t n;

std::cin >> n;

std::ostringstream out;

for (size_t i = 0; i < n; ++i)

{

static short a;

std::cin >> a;

if (a <= 0) out << (i + 1) << ' ';

}

std::cout<<out.str();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ ан массив из n элементов. Необходимо найти количество элементов массива, значения которых неотрицательны и меньше заданного числа A. Формат входных данных С клавиатуры вводится натуральное число n (n≤100 На следующей строке через пробел вводятся n элементов массива. Все числа по модулю не превосходят 100. В последней строке вводится единственное число A (0≤A≤100). Формат выходных данных В качестве ответа выведите единственное число — количество элементов, удовлетворяющих условию. входные данные 5 1 2 3 4 5 3 выходные данные 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vyacheslavovna
okutihamv
DVOct33
Владислав893
Басы: S=0, i=2i&lt;=20S=s+ii=i+2​
ПолухинаТененева565
Vladimirovna1997
ebelskaia
Д.О. Игорь
titov-es3095
Fruktova Gazaryan
taa19707470
александр496
Антон-Марина
Dmitrievna405
▲