Const n=5; var a: array[1..n] of string; c: char; i: integer; begin for i: =1 to n do begin writeln('введите фамилию №',i); readln(a[i]); end; writeln('введите букву'); readln(c); writeln('на букву ',c,' начинаются фамилии: '); for i: =1 to n do if a[i][1]=c then writeln(a[i]); end.тествведите фамилию №1виноградов введите фамилию №2анисимов введите фамилию №3кондратьев введите фамилию №4соколов введите фамилию №5архипов введите буквуана букву а начинаются фамилии: анисимов архипов
ivanpetrovichru1801
24.05.2020
Интерфе́йс по́льзователя, он жепо́льзовательский интерфейс (ui —. user interface) — разновидностьинтерфейсов, в котором одна сторона представлена человеком (пользователем), другая — машиной/устройством. представляет собой совокупность средств и методов, при которых пользователь взаимодействует с различными, чаще всего сложными, машинами, устройствами и аппаратурой. весьма часто термин применяется по отношению к компьютерным программам, однако под ним может подразумеваться набор средств, методов и правил взаимодействия любой системы, человеком. несколько широко распространённых примеров: меню на экране телевизора + пульт дистанционного ; дисплей электронного аппарата (автомагнитолы, часов) + набор кнопок и переключателей для настройки; приборная панель (автомобиля, самолёта) + рычаги . интерфейс двунаправленный(интерактивный) — когда устройство, получив команды от пользователя и исполнив их, выдаёт информацию пользователю наличествующими у неё средствами — визуальными, звуковыми, тактильными и т. п. (приняв которую, пользователь выдаёт устройству последующие команды предоставленными в его распоряжение средствами: кнопки, переключатели, регуляторы, сенсоры, голосом, и т. поскольку интерфейс есть совокупность, то есть он состоит из элементов, которые, сами по себе, также могут состоять из элементов (так, экран дисплея может содержать в себе другие окна, которые, в свою очередь, могут содержать панели, кнопки и прочие интерфейсные элементы). особое и отдельное внимание в интерфейсе пользователя традиционно уделяется его эффективности и удобству пользования (юзабельности). понятный,удобный, дружественный — его основные характеристики.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу паскаль по этой : "сколько ящиков весом 50 кг поместиться в машину если ее грузоподъемность 955 кг"