aerendzhenova5
?>

Решить на паскале я совсем не разбираюсь в ! 1)дана таблица со значениями среднемесячных температур в течение года. составить программу на паскале, в которой вычисляются четыре величины: средние температурызимних месяцев, весенних месяцев, летних и осенних. 2)вы посетили магазин и купили 10 видов товара. в таблицу t [1..10] записали количество купленного товара каждого вида. в таблицу c [1..10] записали цену единицы каждоговида товара соответственно. составить программу на паскале вычисления общей стоимости всех покупок.

Информатика

Ответы

myatadinamo

1)var t: array [1..12] of real;

      i: integer;

begin

  for i: =1 to 12 do readln(t[i]);

  writeln('средняя температура зимних месяцев: '+t[1]+t[2])/3): 0: 3);

  writeln('средняя температура весенних месяцев: '+t[4]+t[5])/3): 0: 3);

  writeln('средняя температура летних месяцев: '+t[7]+t[8])/3): 0: 3);

  writeln('средняя температура осенних месяцев: '+t[10]+t[11])/3): 0: 3);

end.

2)var t: array[1..10] of integer;

          c: array[1..10] of real;

          i: integer;

          s,s1: real;

begin

  s: =0;

  for i: =1 to 10 do begin writeln('введите количество товара'); readln(t[i]) ; end;

  for i: =1 to 10 do begin writeln('введите цену товара'); readln(c[i]); end;

  for i: =1 to 10 do begin s1: =t[i]*c[i];

                                    s: =s+s1;

                            end;

  writeln('общая стоимость всех покупок: ',s: 0: 3);

end.

fakyou170
Для того, чтобы узнать в каком подъезде находится квартира, разделим ее номер на количество квартир в подъезде, на 36. запомним частное и остаток от деления. пусть, к примеру, нам дана квартира 85. делим на 36. получаем частное 2 и в остатке 13. 2 - это номер подъезда. теперь разделим 13 на 4 (число квартир на этаже), запомним частное и остаток. в результате получим 3 и остаток 1. значит, наша квартира на 3-м этаже, и если номера квартир идут слева направо, то квартира будет крайняя слева. итак, квартира с номером 85 находится во втором подъезде, на 3-м этаже нашего дома.
Shurshilina850
1. var x : array[1..1000] of integer;     n,i,max,min : integer; begin write('n = '); readln(n); writeln('исходный массив: '); for i: =1 to n do begin   write('x[',i,']=');   readln(x[i]);   end; writeln; max: =x[1]; min: =x[1]; for i: =2 to n do   begin   if x[i] > max then max: =x[i];   if x[i] < min then min: =x[i];   end; writeln('max=',max,'  min=',min); writeln('среднее = ',(max+min)/2: 5: 2); end. пример: n = 5исходный массив: x[1]=12x[2]=45x[3]=60x[4]=72x[5]=68max=72 min=12среднее = 42.002. begin   var n: =readinteger('n = ');   var a: =readarrinteger('вводите массив: ',n);   writeln('max = ',a.max);   writeln('min = ',a.min);   writeln('среднее = ',(a.max+a.min)/2); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на паскале я совсем не разбираюсь в ! 1)дана таблица со значениями среднемесячных температур в течение года. составить программу на паскале, в которой вычисляются четыре величины: средние температурызимних месяцев, весенних месяцев, летних и осенних. 2)вы посетили магазин и купили 10 видов товара. в таблицу t [1..10] записали количество купленного товара каждого вида. в таблицу c [1..10] записали цену единицы каждоговида товара соответственно. составить программу на паскале вычисления общей стоимости всех покупок.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Liliya1106
vse-v-sad-sdesign
sttig
Людмила902
Irinagarmonshikova
fta1309
borisovaks496
keti0290103
Petrovich
avdoyan6621
Matveevanastya0170
baranova302
vmnk38
Andei
kim-1971