avakarica
?>

Нужно написать программу на паскале! 10 класс! ! в автомастерской имеется список ремонтных работ. на вход подается количество ремонтных работ n, а потом данные, включающие фамилию мастера, продолжительность работы, стоимость работы. 1) отсортировать данные по суммарной продолжительности работ мастеров; 2) вывести на экран тех мастеров , у которых средняя стоимость работы(суммарная стоимость на количество) минимальна; 3) удалить тех мастеров , которые в целом работают меньше заданного времени.

Информатика

Ответы

Титова674
Var n, amount, max_digit, copy_of_n: integer; begin       read(n);       copy_of_n : = n;       amount : = 0;       max_digit : = copy_of_n mod 10;       while copy_of_n < > 0 do       begin                                   {находим наибольшую цифру в числе}           if max_digit < copy_of_n mod 10           then               max_digit : = copy_of_n mod 10;           copy_of_n : = copy_of_n div 10;       end;       copy_of_n : = n;       while copy_of_n < > 0 do         {считаем количество таких цифр}       begin           if copy_of_n mod 10 = max_digit           then               amount : = amount + 1;           copy_of_n : = copy_of_n div 10;       end;       writeln(amount); end.
elav20134518
Var a: array [1..1000] of integer; n, i, max, min, amount: integer; begin       read(n);       for i : = 1 to n do           read(a[i]);       max : = a[1];       min : = a[1];       amount : = 0;       for i : = 1 to n do       begin           if a[i] > max           then               max : = a[i];           if a[i] < min           then               min : = a[i];           if (i mod 2 = 0) and (a[i] < 0)           then               amount : = amount + 1;       end;       writeln('sum of min and max equals ',max + min);       writeln('amount of numbers below zero and on even places: ', amount);       for i : = 1 to n do           if i mod 2 = 0           then               write(a[i], ' '); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу на паскале! 10 класс! ! в автомастерской имеется список ремонтных работ. на вход подается количество ремонтных работ n, а потом данные, включающие фамилию мастера, продолжительность работы, стоимость работы. 1) отсортировать данные по суммарной продолжительности работ мастеров; 2) вывести на экран тех мастеров , у которых средняя стоимость работы(суммарная стоимость на количество) минимальна; 3) удалить тех мастеров , которые в целом работают меньше заданного времени.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zdanovich90764
igraparkGP51
Михайловна-Гусева350
Константой является: b=2; r=56; й: char; ю=2;
Olgachalova111
xeniagolovitinskaya4546
Климова1317
lsyrbu
frame45
Константин Андрей
Диана-Николаевна377
snab54
rn3ay8
sev-94428
l250sp70
amramzi