punchf
?>

Написать программу в pascal.задано число, если оно находится в диапазоне [0, 10] то данное число возвести в квадрат, если нет, то вычислить квадратный корень из числа​

Информатика

Ответы

sklad2445

5a316  = 3·160+10·161+5·162= 3·1+10·16+5·256 = 3+160+1280 = 144310

 

                          0hex = 0dec = 0oct   0 0 0 0     1hex = 1dec = 1oct   0 0 0 1     2hex = 2dec = 2oct   0 0 1 0     3hex = 3dec = 3oct   0 0 1 1                             4hex = 4dec = 4oct   0 1 0 0     5hex = 5dec = 5oct   0 1 0 1     6hex = 6dec = 6oct   0 1 1 0     7hex = 7dec = 7oct   0 1 1 1                             8hex = 8dec = 10oct   1 0 0 0     9hex = 9dec = 11oct   1 0 0 1     ahex = 10dec = 12oct   1 0 1 0     bhex = 11dec = 13oct   1 0 1 1                             chex = 12dec = 14oct   1 1 0 0     dhex = 13dec = 15oct   1 1 0 1     ehex = 14dec = 16oct   1 1 1 0     fhex = 15dec = 17oct   1 1 1 1                          
legezin
Алгоритм выигрыша в этой игре простой: каждый раз надо забирать из кучки m+1 камешек. следовательно, первым ходом надо забрать количество камешков, равное остатку от целочисленного деления n на м+1, а затем в каждый последующий ход забирать столько камешков, чтобы оставшееся их число было кратно m+1. ниже решение на языке borland pascal 7.01 uses crt; var   n,m,k: integer; begin   clrscr;   write('n,m='); read(n,m);   k: =n mod (m+1);   writeln(k);   readkey end. тестовое решение: n,m=7 4 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal.задано число, если оно находится в диапазоне [0, 10] то данное число возвести в квадрат, если нет, то вычислить квадратный корень из числа​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sky-elena712558
maglevanyycpt
Мария
КалюкМарасанов1026
innaterenina
Виктор Попова
Геннадьевна Вета560
Giurievna1977
mberberoglu17
Юлия1689
Ионов202
Татьяна Марина1287
amarantmetall
elenakarpova709
Pokupatel