lena260980
?>

Прошу ! язык - pascal обязательно, чтобы все программы работали при проверке в ! 1. дана строка и некоторое слово. напечатать те предложения строки, которые содержат данное слово. 2. составить программу разложения данного натурального числа на простые множители. например, 200=2³•5². 3. составить программу вычисления суммы факториалов всех четных чисел от m до n. 4. определить наименьший элемент каждой четной строки матрицы a [m, n].

Информатика

Ответы

Египтян2004
Var   a: array[1..10] of integer;   i, sum, count: integer;   average: real; begin   sum : = 0;   writeln('данные о температуре: ');   for i : = 1 to 10 do   begin     a[i] : = random(61) - 30;     sum : = sum + a[i];     write(a[i], ' ');   end;   writeln;   average : = sum / 10;   for i : = 1 to 10 do     if a[i] > average then inc(count);   writeln(count, '  раз(a)'); end.
Грудинин604
)ввести строку. удалить первое слово.  2) в введенном тексте сочетание “and” заменить на “or”.  3) ввести строку. определить количество слов, содержащих букву z  4) n=15 определить, каких элементов больше положительных или отрицательных элементов массива  5) в массиве хранятся оценки, выставленные спортсмену судьями. определить , идущий спортсмену в зачет по олимпийской системе (средний без учета максимального и ми-нимального) .  6) определить, образуют ли элементы, стоящие на нечетных номерах, убывающую последовательность.  7) массив хранит оценки экзаменов 10_ти студентов по 5_ти предметам. организовать заполнение массива случайными значениями от 2 до 5. определить количество предметов, по которым были получены только оценки «5» и «4».  8) вывести все элементы массива а (5,5), располагающиеся ниже главной диагонали.  9) дан двумерный массив mas. ввести a (номер строки) и b (номер столбца) определить сумму всех ближайших соседних элементов для mas[a,b].  10) вычислить нод (a,b,c)+нод (a,b,c,d), используя функцию нахождения нод (наибольшего общего делителя) для двух чисел.  11) ввести три числа. найти сумму первых цифр каждого числа, используя процедуру, которая оставляет только первую цифру числа.  например, даны 12, 520, 231, результат 1+5+2=8  12) вывести на экран только те строки исходного файла, которые состоят из одного слова.  13) удалить из файла самую длинную строку (сформировать новый файл)   нравится

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прошу ! язык - pascal обязательно, чтобы все программы работали при проверке в ! 1. дана строка и некоторое слово. напечатать те предложения строки, которые содержат данное слово. 2. составить программу разложения данного натурального числа на простые множители. например, 200=2³•5². 3. составить программу вычисления суммы факториалов всех четных чисел от m до n. 4. определить наименьший элемент каждой четной строки матрицы a [m, n].
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pivenraisa
olartamonov6
aaazovcev
Лилит_Шутова
ulechkaevseeva
Fedorovich309
sergeevna
afilippov3321
Вадим
kep92
pronikov90
YelenaZOLTANOVICh105
uglichwatch
svetavancevich
AlekseiBunina1895