усложнённый вариант(всё работает исправно,при вводе больше или меньше 3 чисел выводится сообщение "это не трёхзначное число! "):
vari,a,d: integer; s: string; beginwriteln('введите трёхзначное число '); read(s); d: =length(s); if d< > 3 thenwrite('это не трёхзначное число! '); if d=3 thenif (s[1]=s[2])or(s[1]=s[3])or(s[2]=s[3]) thenwrite('да')elsewrite('нет'); end.
простой вариант(выводится ошибка если цифр больше или меньше трёх! ):
vari,a,d: integer; s: string; beginwriteln('введите трёхзначное число '); read(s); if (s[1]=s[2])or(s[1]=s[3])or(s[2]=s[3]) thenwrite('да')elsewrite('нет'); end. 2 варианта, так-как незнаю,проходили ли вы функцию "length" или нет.если нет,то препад заподозрит что вы списали откуда нибудь или вам кто-то подсказал.
быол бы неплохо указывать среду прoграммирования.paskal.
program massiv; uses crt; var a: array [1..200] of integer; n, i, k, s: integer; begin; clrscr; writeln ('введите количество элементов в массиве'); readln(n); randomize; writeln ('задан массив'); for i: =1 to n do begin a[i]: =-10+random(21); write (a[i], ' '); end; writeln; writeln ('введите число'); {кратное которому необходимо найти}readln (k); for i: =1 to n do
if (a[]i]< > 0) and (a[i] mod k = 0) then s: =s+1;
write ('количество элементов кратных введенному числу - ', s);
readkeyend.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая при вводе латинской буквы сообщает главная она или согласная. использовать тип данных символьный char.
var c: char;
vowels: set of char: =['a', 'e', 'i', 'o', 'u', 'y'];
begin
write('введите символ: ');
readln(c);
if c in vowels then
writeln(c, ' — гласная')
else
writeln(c, ' — согласная');
end.