juli19657
?>

Напишите программу для вычесления скорости. ​

Информатика

Ответы

rubanvladimir374
Const n=10; var a,g: array [1..100] of integer; var b : array [1..100] of string; var k: integer; begin writeln ('ответы вводятся строкой без пробелов. пример: 12345'); b[1]: ='1. общество в широком смысле слова – это '+newline+ ' 1) территория обитания людей'+newline+ ' 2) человечества'+newline+ ' 3) совокупность форм объединения людей'+newline+ ' 4) производительные силы'; b[2]: = '2. обществознание – это '+newline+ ' 1) наука'+newline+ ' 2) учебная дисциплина'+newline+ ' 3) комплекс наук об обществе и человеке'+newline+ ' 4) сфера естественнонаучного знания'+newline+ ' 5) сфера гуманитарного знания'; b[3]: = '3. человек отличается от животного наличием'+newline+ ' 1) языка'+newline+ ' 2) разума'+newline+ ' 3) сознанием'+newline+ ' 4) трудовой деятельности'+newline+ ' 5) мышления'; b[4]: = '4. личность возможна (определить неверный ответ)'+newline+ ' 1) без морали'+newline+ ' 2) без гражданственности'+newline+ ' 3) без ответственности'+newline+ ' 4) без диплома о высшем образовании'; b[5]: = '5. человек и общество'+newline+ ' 1) человек первичен по отношению к обществу'+newline+ ' 2) общество первично по отношению к человеку'+newline+ ' 3) человек и общество взаимно обусловлены'+newline+ ' 4) общество и человек развиваются независимо друг от друга'; b[6]: = '6. мораль в религии основывается'+newline+ ' 1) на разуме'+newline+ ' 2) на вере'+newline+ ' 3) на долге'+newline+ ' 4) на свободе'; b[7]: = '7. целью развитой религии является достижение'+newline+ ' 1) материального благополучия'+newline+ ' 2) социального положения и значимости'+newline+ ' 3) спасение души'+newline+ ' 4) познание мира'+newline+ ' 5) силами природы'; b[8]: = '8. к монотеистическим религиям относятся'+newline+ ' 1) индуизм'+newline+ ' 2) ислам'+newline+ ' 3) буддизм'+newline+ ' 4) язычество'; b[9]: = '9. к основным моральным категориям относятся (определить неверный ответ)'+newline+ ' 1) добро'+newline+ ' 2) справедливость'+newline+ ' 3) совесть'+newline+ ' 4) выгода'+newline+ ' 5) любовь'; b[10]: = '10. мораль проявляется в следовании'+newline+ ' 1) интересам власти'+newline+ ' 2) общественному мнению'+newline+ ' 3) анимизму'+newline+ ' 4) гороскопу'+newline+ ' 5) внутреннему «я» человека'; a[1]: =3; a[2]: =23; a[3]: =12345; a[4]: =4; a[5]: =3; a[6]: =2; a[7]: =3; a[8]: =23; a[9]: =4; a[10]: =5; k: =0; for var i: =1 to n do begin   writeln(b[i]);     readln(g[i]);   if g[i]=a[i] then k: =k+1; end; writeln ('ваша оценка: ',k/2); end.
jim2k
// pascalabc.net 3.2, сборка 1374 от 10.01.2017// внимание! если программа не работает, обновите версию! procedure myarray(n: integer; var a: array of integer); begin  a: =arrfill(n,0); // заполняем массив нулями  randomize; // инициализируем датчик случайных чисел  // в случайный элемент заносим слчайное значение  a[random(0,n-1)]: =random(1,99)end; begin  var n: =readinteger('n='); // читаем с клавиатуры размер массива  var mas: array of integer;   myarray(n,mas); // вызываем процедуру  mas.println // выводим сформированный массивend. пример n= 21 0 0 0 0 0 0 0 56 0 0 0 0 0 0 0 0 0 0 0 0 0

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для вычесления скорости. ​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

choia
natura-domA90
игнатова_Сергей1228
info6
batalerka391
Ryadovboxing23
coffee2201
tushina2020
makashi28
alexeytikhonov
margarita25061961
Lidburg
Руслан1360
proh-dorohova5244
kireevatatiana