eurostom
?>

Написать программу для решения . дана строка, содержащая текст. сколько слов в тексте? сколько цифр в тексте?

Информатика

Ответы

metelkin7338

ответ:

{подсчёт числа символов цифр в строке}

var s: string;   i,n: integer;

begin

        readln(s);

        n : = 0;

        for i: =1 to length(s) do begin // обходим строку в цикле

                if (s[i]> ='0')and(s[i]< ='9') then inc(n);

        end;

      writeln('this string contains ',n,' digits.'); // выводим массив

end.

Marina281

program raf105;

var  

  s,s1,s2: string;

  slov,numb,i,j: integer;

begin

writeln('введите строку: ');

readln(s);

s: = lowercase(s);

s1: = 'йцукенгшщзхъфывапролджэячсмитьбюёqwertyuiopasdfghjklzxcvbnm';

s2: = '1234567890';

for i: =1 to length(s1) do

  if s[1] = s1[i]

    then slov+= 1

    else if (i< =length(s2)) and (s[1] = s2[i])

      then numb+=1;

for i: =2 to length(s) do

begin

  if s[i] = ' '

    then  

    begin

      for j: =1 to length(s1) do

        if s[i+1] = s1[j]

          then slov+= 1;

    end

    else

    begin

      for j: =1 to length(s2) do

        if s[i] = s2[j]

          then numb+= 1;

    end; ;

end;

writeln;

writeln('в строке: ');

writeln(slov,' сл.');

writeln(numb,' циф.');

end.

язык pascalabc
Timurr007

#include <iostream>

#include <vector>

#include <algorithm>

using namespace std;

int main()

{

   vector <int> arr1;

   vector <int> arr2;

   int n;

   

   cin >> n;

   for(int i = 0 ; i < n ; ++i)

   {

       int temp; cin >> temp;

       arr1.push_back(temp);

   }

   cin >> n;

   for(int i = 0 ; i < n ; ++i)

   {

       int temp; cin >> temp;

       arr2.push_back(temp);

   }

   for(int i = 0 ; i < arr1.size() ; i++)

       if(find(arr2.begin(), arr2.end(), arr1[i]) == arr2.end())

           cout << arr1[i] << ' ';

}

Алексей Ксения

ЭВМ задумывалась создателями как многофункциональная машина заменить со временем многие устройства, предоставить доступ к электронной информации. Позже появилась возможность объединить поумневшие агрегаты в единую сеть. Теперь, благодаря высоким технологиям, человек получил доступ к информации со всего мира, может общаться и работать на различных ресурсах, отдыхать и путешествовать. Но, увы! Со всеми благами компьютер принес в нашу жизнь и проблемы.

Сегодня многие задают во Компьютер – это хорошо или плохо?» Машина сама по себе безвредна, ведь производители шагнули далеко вперед, создавая безопасные для глаз мониторы, эргономичные периферийные устройства. Все проблемы компьютерного века в самом человеке. И разделить их можно на две категории. На одном берегу будут недобросовестные поставщики услуг и контента, а на другом - неподготовленные пользователи. Одни предоставляют поля, на которых цветут все человеческие страсти и отклонения, другие предаются им с удовольствием. Игромания, насилие, искажение фактов и реалий, навязчивая реклама, сомнительные социальные ориентиры оказывают губительное влияние на интеллект, психику и нравственность ребенка, вышедшего на всемирной сети без контроля взрослых. И сеть ловит, высасывает, ломает жизни.

На плечи взрослых ложится задача по контролю обеих сторон. А перед подрастающим поколением стоит цель:  научиться отделять добро от зла до того, как сядет в удобное кресло. Ведь сегодня недостаточно вырвать ребенка из сети. Нужно будет отвлечь от бесконечного сидения в псевдомире, созданном из фото, видео и игр. Научить жить: радоваться реальному миру, любить, созидать, творить, проявляя себя достойным человеком.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу для решения . дана строка, содержащая текст. сколько слов в тексте? сколько цифр в тексте?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

myataplatinumb348
Dmitrii sergei463
Dampil
vusokaya13
ilysozkn27
dddandmvd5210
gigbes
choia
angelinaugan119
Давид-Александр
natkoff5
AkulovaAnastasiya
bestform
annabanova9
Chopper-hinter25