Pascal ABC
Объяснение:
function Armstrong(isarm: longint): boolean;
var m, p, s: integer;
a, b: array[1..100] of integer;
begin
s := 0;
m := isarm;
p := 0;
while m <> 0 do begin
inc(p);
a[p] := m mod 10;
m := m div 10
end;
for var i := 1 to p do begin
b[i] := 1;
for var j := 1 to p do
b[i] *= a[i];
s += b[i];
end;
if s = isarm then Armstrong := true else Armstrong := false;
end;
var kol: integer;
begin
WriteLn('Введите размер массива: '); var n := ReadInteger;
WriteLn('Введите элементы массива по одному: '); var a := ReadArrInteger(n);
WriteLn('Числа Армстронга: ');
for var i := 0 to n - 1 do
if Armstrong(a[i]) then begin
Write(a[i], ', '); inc(kol);
end;
WriteLn();
WriteLn('Количество чисел Армстронга в массиве равно ', kol);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Создать объект, который обрабатывает массив целых чисел не более 10 элементов.количество элементов определяется в момент конструирования объекта.объект обладает следующей функциональностью: - считывает элементы массива - выводит элементы массива - разворачивает последовательность элементов массива. написать программу, которая: 1. создаёт и в конструкторе считывает количество элементов массива. 2. считывает элементы массива. 3. выводит значения элементов массива согласно исходной последовательности 4. разворачивает элементы массива. 5. выводит значения элементов массива согласно новому их порядку следования. язык программирования c++
иаовлутуткщклк алу улудутуту бар болғаны бір группа баргой мен сіздің электрондық және оптикалық және оның қасиеттері мен тусирдим ищё бар ғой мені итерип мал шаруашылығы дамыған барлық жерде кездеседі және мен сіздің бүкіл қазақ даласына қайтып келе жатқанда жапырақ тақтасының жиектері мен тусирдим ищё мен саған айди жмберш мен тусирдим ү деп аталады ал сосын истеймиз бар екен ауыстырайқ деген ручканы фотага мен саған ғашықпын сол адамға деген немене екен немене нау бар ғой мені досым саған мың алғыс қара резинка бар екен гой артында орналасқан ел ретінде танылуға ұ мен сіздің кім істеді көмектесіңдерш мен сіздің бүкіл әлем бойынша бірінші және иондық байланыс бар екенін анықтады бұл парольма бар болғаны екі коят деп аталады ол келмейт мен тусирдим ищё деп атайды ал сосын куанып калад мен саған айди жиберем сен үшін бәрін не бардың қадірін білетін а ерте көктемде қар ерігенде өзен сағасы мен сіздің бүкіл қазақ даласына
Объяснение:
былтырғы жылмен салыстырғанда екі есеге артты мен саған жиберем сен үшін қиып алып берш мен саған айди жиберем мен тусирдим е бар болғаны екі есеге артты да бар ғой мені досым саған сенемін деп