Браузер – это программа для веб-страниц. Если вы читаете эту веб-страницу, то объяснять, что это за программа и зачем она нужна, думаю, особого смысла нет.
На сегодняшний день в Интернет стало огромное количество браузеров от самых разных производителей. Для того, чтобы работать с HTML, может подойти любой из них. На начальном этапе этого достаточно.
В будущем, когда ваш профессионализм будет расти, вам может понадобиться установить сразу несколько браузеров на ваш компьютер. Это делается для того, чтобы была возможность тестирования отображения страниц в браузерах от разных производителей.
К сожалению, в деле веб-разработки не правильная работа страниц в разных браузерах далеко не редкость.
На всякий случай дам ссылки на наиболее популярные браузеры, которые вы можете использовать в своей работе.
2) Программа для создания и редактирования кода.
Следующий инструмент, который нам понадобится – это программа с которой можно создавать и редактировать HTML-код.
Здесь вариантов, на которых можно остановиться тоже очень много.
Если вы помните из заметки, HTML-документ – это обычный текстовый файл, поэтому работать с ним можно в любом текстовом редакторе. Это можно делать даже в стандартном приложении «Блокнот», который входит в стандартный пакет программ от Windows. Позже посмотрим, как это можно сделать.
Есть и другие продвинутые текстовые редакторы, которые более адаптированы к работе с кодом.
Например,
Notepad++
Объяснение:
Напишите программу (python), которая соберет все подарки Иа от всех друзей.
Формат ввода
Целое число — количество строк, затем сами строки, в которых сначала вводится подарок, а потом через дефис, окруженный пробелами, имя друга.
Формат вывода
Вывести для каждого друга (друзья выводятся в обратном алфавитном порядке) список его подарков Иа, но уже в алфавитном порядке. Формат вывода:
Друг: подарок, подарок, подарок
Ввод
5
Букет из чертополоха - Кролик
Бант для хвоста - Кристофер Робин
Гвоздик для хвоста - Кристофер Робин
Спаржевый пудинг - Кролик
Зеленая тряпочка - Пятачок
Вывод
Пятачок: Зеленая тряпочка
Кролик: Букет из чертополоха, Спаржевый пудинг
Кристофер Робин: Бант для хвоста, Гвоздик для хвоста
Поделитесь своими знаниями, ответьте на вопрос:
var a, b: integer;
begin
readln(a);
readln(b);
write('среднее арифметическое= ',(a+b)/2);
end.