Sergeevich-irina
?>

Напишите программу в паскаль: 3x-9, если x< =7 f(x)= 1/x(в квадрате)-4, если x> 7

Информатика

Ответы

ДеречинскийИрина1149

построить график: y = 1.5x2 + 2x - 10

с шагом 0.5область определения от -5 до 5 

1. напишем в ячейках a1 a2 a3 коэффиценты 1.5 2 и -10

2. в ячейке a3 обозначим x

в ячейке a4 обозначим y

3. ячейку b3 заполняем значением "-5", хватаем за черный маркер правой кнопкой мыши и тянем до v3, появляется меню, там выбираем пункт "прогрессия" и устанавливаем шаг 0.5

4. теперь заполним y, в клетку в4 добавляем формулу "=$a1*b3^2+$b1*b3+$c1" и тянем её за маркер до v4 

далее выделяем диапозон клеток b3: v4

5. жмем вставка, "точечная с гладкими кривыми"

готово, график построен, теперь меняем его внешний вид и оформляем таблицупример выполненной работы:

h777eta

обе програмки проверены на авс паскале. работают : )

 

program user6165_1; const n=10; var  a: array[1..n,1..n] of integer;   stosum: array[1..n] of integer; //массив для хранения сумм столбцов  i,j,nomer,sum : integer; begin  randomize;   for i: =1 to n do      for j: =1 to n do          a[i,j]: = random(100); //заполняем массив  writeln('*** alphaues is ***');   for j: =1 to n do      begin           sum: =0;             for i: =1 to n do              sum: =sum+a[i,j]; // находим сумму столбца          stosum[j]: =sum;       end;   nomer: =1;   sum: =stosum[1];   for j: =1 to n do      begin          if sum< stosum[j] then sum: =stosum[j];           nomer: =j;       end;   writeln;   for i: =1 to n do      begin           for j: =1 to n do              write(a[i,j]: 5); //выводим массив          writeln;       end;       writeln('*** столбец с максимальной суммой - ',nomer,'-й'); end.program user6165_2; const n=10; var  a: array[1..n,1..n] of integer;   stosum: array[1..n] of integer; //массив для хранения сумм столбцов  i,j,nomer,min : integer; begin  randomize;   for i: =1 to n do      for j: =1 to n do          a[i,j]: = random(100); //заполняем массив  writeln('*** alphaues is ***');   writeln;   for i: =1 to n do      begin           for j: =1 to n do              write(a[i,j]: 5); //выводим массив          writeln;       end;   for i: =1 to n do      begin           min: =a[i,1];             nomer: =1;           for j: =1 to n do              if min> a[i,j] then              begin                  min: =a[i,j];                   nomer: =j;               end;           if nomer< n then           begin              a[i,nomer+1]: =1;               writeln(i,'-я строка: мин. элемент - ',nomer,'-й. следующий заменён на 1.');           end          else              writeln(i,'-я строка: мин. элемент - ',nomer,'-й. это последний элемент в строке.');       end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в паскаль: 3x-9, если x< =7 f(x)= 1/x(в квадрате)-4, если x> 7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

qelmar461
melnik-738
Борисовна_Кашутина
konnovakat1
mikek0906
ilma20168
Soliyabronzoni
ti2107
Alexander2035
mail2017
Voronov434
annatarabaeva863
nusupova
kronid12
dima0218687
▲