galinaobraz
?>

Написать программу, которая находит количество двузначных чисел , среди введенных пользователем положительных чисел. пользователь вводит количество чисел, затем сами числа.​

Информатика

Ответы

okasnab

ответ: в

объяснение: псевдокод - описание структуры алгоритма на естественном,   частично формализованном языке, позволяющее выявить основные этапы решения , перед точной его записью на языке программирования. в псевдокоде используются некоторые формальные конструкции и общепринятая символика. строгих синтаксических правил для записи псевдокода не существует. это облегчает запись алгоритма при проектировании и позволяет описать алгоритм, используя любой набор команд. однако в псевдокоде обычно используются некоторые конструкции, присущие формальным языкам, что облегчает переход от псевдокода к записи алгоритма на языке программирования. единого или формального определения псевдокода не существует, поэтому возможны различные псевдокоды, отличающиеся набором используемых слов и конструкций.

Oksana-Kirakosyan1301
Const n=5; var  a: array[1..n,1..n] of integer; b: array[1..n] of integer; i,j,max,min,s: integer; begin randomize; writeln('исходный массив: '); for i: =1 to n do   begin   for j: =1 to n do   begin     a[i,j]: =random(21);     write(a[i,j]: 4);   end;   writeln;   end; max: =a[1,n]; for i: =2 to n do   if a[i,n-i+1]> max then max: =a[i,n-i+1]; writeln('1. max = ',max); for i: =1 to n do   begin   min: =a[i,1];   for j: =2 to n do   if a[i,j]< min then min: =a[i,j];   b[i]: =min;   end; s: =0; writeln('2. массив b'); for i: =1 to n do    begin   write(b[i]: 4);   s: =s+b[i];   end; writeln; writeln('3. среднее = ',s/n); for i: =1 to n do    if b[i]> s/n then write(b[i]: 4); writeln; end. пример: исходный массив:   10   19   15   17   10   12   12   10   1   5   17   8   8   14   15   12   11   8   0   13     2   2   4   10   6 1. max = 11 2. массив b   10   1   8   0   2 3. среднее = 4.2   10   8

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая находит количество двузначных чисел , среди введенных пользователем положительных чисел. пользователь вводит количество чисел, затем сами числа.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Svetlana1884
kuchin
Aleksei Biketova
TatarkovTitova
vs617
Platon
Taurus59707
Olegmgu11986
Dmitrievich1871
Алексеевна
oduvanalex
natachi
pechyclava
Melsan19914239
Стародубцева_Васильевич485