kuliba
?>

Создать массив из 20 случайных элементов. подсчитать в нем сумму нечетных отрицательных элементов и количество элементов, кратных 5. нид паскаль

Информатика

Ответы

Бернард pokerman

const n = 10; var i: integer; mas : array[1..n] of integer; max_num, max_index: integer; begin writeln('введите элементы массива'); for i: =1 to n do readln(mas[i]); for i : = 2 to n do if mas[i] > max_num then begin max_index : = i; max_num : = mas[i]; end; writeln('максимальное число ',max_num,' находится на позиции ',max_index); end.

 

 

 

 

объяснение - 

константы:

n- это сколько чисел будет в твоём массиве

max_num - максимальное число 

max_index - позиция числа

 

функции :

for i: =1 to n do readln(mas[i]); - вводим числа в массив

 

 

for i : = 2 to n doif mas[i] > max_num then beginmax_index : = i; max_num : = mas[i]; end;

 

ищем максимальное число и его позицию

Титова674

в обоих нет самомого главного - не описан интерфейс с пользователем, функции пользователя и функции программы. без этого программа не пишется. ведь ты, по сути, формулируешь техническое на программирование, а в нём не должно быть неясностей для программиста, он   должен взять листочек и тупо закодировать то, что там написано.

ну, например, по 1 могут быть варианты:

1. написать программу, которая при этом в каждом поединке победа присуждается с вероятностью 1/3, поражение с вероятностью 1/2, ничья с вероятностью 1/6. по окончании расчетов вывести турнирную таблицу в порядке занятого места.

 

в этом случае пользователь ничего не делает и интерфейса, как такового, нет, он просто нажимает "пуск", а программа всё сама делает и выводит результаты на печать.

 

2. написать программу, при этом участники каждого турнира выводятся на экран, а пользователь сам определяет его результат(победа, ничья, поражение). по окончании турниров программа віводит турнирную таблицу в порядке занятого места.

 

в этом случае пользователь всё время в диалоге, потому что именно он должен определять результат каждого турнира.

 

вот 2 разных сценария интерфейса к одному и тому же, что написано в , но программы, их сложность достаточно различаются.

 

резюме. если хочешь, чтобы тебе качественно , а не отписались, сформулируй снова, лучше каждое отдельным и так, чтобы тебе самой было понятно, что ты хочешь от программы.

успехов!

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Создать массив из 20 случайных элементов. подсчитать в нем сумму нечетных отрицательных элементов и количество элементов, кратных 5. нид паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Shurshilina850
Иванов1813
nurtilekisakov
Андреевич-Екатерина1974
snab54
milkline-nn
АльбертовичБерезин58
POMILEVAVladimirovna269
natachi
Stroeva19651938
inainainainaina0073
tol1974656
zloshop9
Дил1779
Татьяна-Мария