praktikadok
?>

Напишите программу, которая вводит трехзначное число и находит сумму цифр этого числа.

Информатика

Ответы

dima-pashkovec
Чтобы выражение было истинным, необходимо, чтобы (х > 4) и ((х < 10) или (х < 13)) были истинными одновременно.чтобы ((х < 10) или (х < 13)) было истинными, необходимо, чтобы либо (х < 10), либо (х < 13) были истинными, либо оба одновременно. => 13> x> 4 => всего 8 чисел (12, 11, 10, 9, 8, 7, 6, 5)можно проверить: (12 > 4) и ((12 < 10) или (12 < 13)) =1 и (0 или 1)=1и1=1 (11 > 4) и ((11 < 10) или (11 < 13)) =1 и (0 или 1)=1и1=1 (10 > 4) и ((10 < 10) или (10 < 13)) =1 и (0 или 1)=1и1=1 (9 > 4) и ((9 < 10) или (9 < 13)) =1 и (1 или 1)=1и1=1 (8 > 4) и ((8 < 10) или (8 < 13)) =1 и (1 или 1)=1и1=1 (7 > 4) и ((7 < 10) или (7 < 13)) =1 и (1 или 1)=1и1=1 (6 > 4) и ((6< 10) или (6 < 13)) =1 и (1 или 1)=1и1=1 (5 > 4) и ((5 < 10) или (5 < 13)) =1 и (1 или 1)=1и1=1ответ: 8
larisau41
Program prog1; uses crt; var a: array [1..50] of integer;       k, i: integer; begin clrscr; randomize; for i: =1 to 50 do begin a[i]: = random(41); write(a[i],'  '); if a[i]=23 then inc(k); end; writeln; writeln; writeln('k = ',k); end. program prog2; uses crt; var a: array [1..50] of integer;       i: integer; begin clrscr; randomize; for i: =1 to 50 do begin a[i]: = random(41); write(a[i],'  '); if (a[i] mod 5) =0 then a[i]: =-1; end; writeln; writeln; for i: =1 to 50 do write(a[i],'  '); end. program prog3; uses crt; var a: array [1..10] of integer;       tmp, i: integer; begin clrscr; randomize; for i: =1 to 10 do begin a[i]: = random(41); write(a[i],'  '); end; tmp: =a[2]; a[2]: =a[9]; a[9]: =tmp; writeln; writeln; for i: =1 to 10 do write(a[i],'  '); end. program prog4; uses crt; var a: array [1..100] of integer;       n, i,k: integer; begin clrscr; randomize; write('n = '); readln(n); for i: =1 to n do begin a[i]: = random(41); write(a[i],'  '); end; writeln; writeln; for i: =1 to n-1 do if ((a[i] mod 10)=2)and((a[i+1] mod 10)=2) then inc(k); writeln('k = ', k); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вводит трехзначное число и находит сумму цифр этого числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Puschdom
михаил
vlsvergun59
diana8
Ирина-Макаркина253
arbat
st-op767840
yakushkinayuliya
garikman-flesh486
delfinmos
ЮрьевичКарпова1564
lebedev815
Kuznetsova702
grazia2017
orantus3
▲