fhf3624
?>

Стоимость одного килограмма конфет 2.50 напишите программу в pascal, которая запрашивает кол-во купленных килограммов, вычисляет стоимость и выводит результат на экран.

Информатика

Ответы

алексеевич810

ответ:

program zz1;

const n = 12;   // задаем количество элементов в массиве

var   i, k, k1, s, c: integer; // задаем переменные целого типа

m: array [1..n] of integer;

begin

write(' введите заданное число ');

read(c);

for i: =1 to n do   // получаем n чисел случайных и записываем их в массив

m[i]: =random(51);

for i: =1 to n do   // выводим полученный массив на экран

write(m[i],' ');

writeln;     // переходим на новую строку для вывода ответа

for i: =1 to n do   // организуем цикл, в котором переберем все элементы массива

begin

  if i mod 2 = 1 then begin s: =s + m[i]; k: =k+1; end; // получаем сумму и количество элементов на нечетных местах

  if m[i] < c then k1: =k1 + 1; // получаем количество элементов меньших заданного

end;

writeln( ' среднее арифметическое чисел стоящих на нечетных местах = ', s/k: 5: 2);   //выводим ответ

writeln( ' количество чисел меньших заданного с = ', k1);

end.

объяснение:

shangina1997507

ответ:

1)

program next;

var a,s,d,f,g,h: integer;

begin

read(h);

for a: =1 to h do

begin

read(d);

if (d mod 4 =0)then

begin

f: =f+1;  

end;  

end;  

writeln(f);

end.

2)

program next;

var a,s,d,f,g,h: integer;

begin

read(h);

for a: =1 to h do

begin

read(d);

if (d mod 6 =0)then

begin

f: =f+d;  

end;  

end;

writeln(f);

end.

3)

program next;

var a,s,d,f,g,h: integer;

begin

for a: =1 to 1000 do

begin

read(d);

if d=0 then

begin

break;  

end;

if (d> 9)and(d< 100)then

begin

if (d mod 5 =0)then

begin

f: =f+1;  

end;  

end;

end;

writeln(f);

end.

4)

program next;

var a,d,f,g,h: integer;

s: real;

begin

for a: =1 to 1000 do

begin

read(d);

if d=0 then

begin

break;  

end;

if (d> 0)then

begin

if (d mod 8 =0)then

begin

h: =h+1;  

f: =f+d;

end;

end;  

end;

if (h> 0)then

begin

s: =f/h;

writeln(s);

end

else

begin

writeln('0');  

end;

end.

объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Стоимость одного килограмма конфет 2.50 напишите программу в pascal, которая запрашивает кол-во купленных килограммов, вычисляет стоимость и выводит результат на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tenvalerij
inessa12006
Наталья
margarita25061961
cheshirsky-kot
Vladimirovna1370
alenchik19938823
Дмитрий_Владимирович1162
Микроволновые системы что это​
mlf26
dmitrievanata83538
kristina1989
egamedicalbuh
andreanikin
zibuxin6
gabramova