ekrosenergoserv
?>

Решить: определите значение целочисленных переменных х, y, z после выполнения фрагмента программы: x: = 13 y: = 3 z: =x x: = z div y y: = x

Информатика

Ответы

Viktorovna

x: = 13         x = 13

y: = 3           y = 3

z: =x             z = 13

x: = z div y   x = 4

y: = x           y = 4

 

ответ: 4, 4, 13

skachmin

для початку давайте розберемося в тому, що саме являє собою форматування диска, і чому після нього є реальна можливість відновити якщо не всі, то більшу частину даних. при первинному (або нізькорівневому ) форматуванні відбувається створення файлової таблиці, в яку система записує всі дані, необхідні для роботи. коли запускається процес форматування диска, таблиця нікуди не дівається, а лише обнуляється. стара інформація, яка перебувала в ній, не може відповідати розмірам таблиці, тому стає просто невидимою для системи. і якщо на диск не проводився запис нових даних, тоді відновити файли після форматування диска можна.

слід враховувати і те, тип якого форматування ви використовували. якщо було вибрано швидке форматування, тоді відбувається тільки очищення заголовків файлової системи, а от інформація з жорсткого диска нікуди не видаляється. на щастя, в більшості випадків використовують саме швидке форматування.

при повному форматуванні в кожному секторі жорсткого диска видаляється вся інформація, тому відновлення даних в такому випадку являє собою практично неможливу .

незважаючи на всі проблеми після форматування диска дані можна відновити. справа в тому, що пошук даних після форматування по своєму процесу нічим не відрізняється від відновлення даних після їх видалення з комп'ютера. правда, в силу того що потрібно відновлювати цілий диск, то операція ця займає чимало часу.

для відновлення даних після форматування дуже важливо не записувати зверху ніяку інформацію. створення нових папок і установка системи зводить ваші шанси на відновлення втраченої інформації до мінімуму. зауважте, що після форматування операційні системи xp і vista самі створюють деякі папки. також після форматування диска, якщо є можливість, не перезавантажуєте комп'ютер, а просто вимкніть його.

щоб відновити дані з диска, знадобиться інший комп'ютер, на який попередньо встановлюють спеціальну програму. потім до комп'ютера підключають диск, який потрібно відновити, і запускають сканер. після закінчення сканування диска, вам буде зрозуміло, що саме вдасться відновити, а що - ні.

зверніть увагу на те, що для відновлення даних вам знадобиться комп'ютер, у якого обсяг диска перевищує ваш.

ми розібралися з тим, як відновити файли після форматування, тепер же поговоримо про те, які програми можна використовувати для цього. є маса безкоштовних і ліцензійних утиліт, які вам впоратися з цим завданням. таке зійде

Fedorovich309
1. решается с стека (алгоритм дейкстры для обработки обратной польской записи). предполагается, что во вводимой строке содержится корректное выражение, удовлетворяющее условиям . // pascalabc.net 3.3, сборка 1555 от 21.10.2017 // внимание! если программа не работает, обновите версию! begin   var w: =readlnstring.towords;   var st: =new stack < integer> ;   var r: =0;   foreach var t in w do       if t[1].isdigit then st.push(t.tointeger)       else begin           var a: =st.pop;           var b: =st.pop;           case t[1] of           '+': st.push(a+b);           '-': st.push(b-a);           '*': st.push(a*b)           end;       end;   writeln(st.pop)  end. контрольный пример 8 9 + 1 7 - * -102 2. крайне просто решается при регулярного выражения с рекурсией. фактически вводить количество шаров не нужно, поэтому после ввода оно отбрасывается. // pascalabc.net 3.3, сборка 1555 от 21.10.2017 // внимание! если программа не работает, обновите версию! begin   writeln(readlnstring.towords.skip(1).joinintostring('').           matchvalue('{2,}').length); end. контрольный пример 5 2 3 3 3 1 3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить: определите значение целочисленных переменных х, y, z после выполнения фрагмента программы: x: = 13 y: = 3 z: =x x: = z div y y: = x
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

elenaneretina
akudryashov
radatailless
tyrenumberone
nadlen76
denbelousov963
Bmashutav16
savenko0109152
char40
peresvetoff100015
Рогов1996
Galiaahmatova4447
teya07
arch5050
agutty3
▲