Paikina Natalya30
?>

Составить программу.паскаль. найти сумму чисел, делящихся без остатка на 4, меньших 100 и заканчивающихся на 2 или 8.

Информатика

Ответы

nikolavlad

var i,s: integer; begin s: =0; for i: =0 to 100 do begin if (i mod 4 = 0) then for i: =0 to 100 do if (i mod 10=2) or (i mod 10=8) then s: =s+i; ; write('summa = ',s); end; end.

balabinatanya7174
#include < iostream> using namespace std; //функция возвращает минимальное возможное число,//состоящее из цифр числа aint min(int a) { //массив для подсчета цифр в числе int *k = new int[10]; for (int i = 0; i < 10; i++) k[i] = 0; //считаем, сколько раз повторяется каждая цифра в числе for (; a; a /= 10) { int t = a % 10; //если цифра не 0 if (t) k[t]++; } //переменная для результата int rez = 0; //множиель разряда int multiplier = 10; //идем по массиву в обратном порядке for (int i = 9; i > 0; //если данная цифра есть в массиве (числе) for (; k[i]; { //дописываем цифру в результат rez += i * multiplier * 0.1; //увеличиваем множитель, для перехода к следующему разряду multiplier *= 10; } //удаление массива delete[] k; return rez; } void main(){ //входные данные int n; printf("\n < < n = "); scanf("%d",& n); //вывод результата printf("\n > > min = %d", min(n)); system("pause> > void"); }
ribcage52
1способ                             2 способ 1)22-10=12                           х+х+10+22 2)12/2=6                              2х=12 либо (22-10)/2                      х=12/2                                               х=6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу.паскаль. найти сумму чисел, делящихся без остатка на 4, меньших 100 и заканчивающихся на 2 или 8.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ivanovna
Александр Сергей
Владимировна Екатерина
saint158
mos197653
sdvigov
Шавкат кызы
macmakka
yuliyastatsenko3894
ambstroy
vickuznetsova8677
mototeh69
olyafom1234
elenak26038778
pavlova7771960
▲